Trouble with Developer Studio on mangOH Virtual Machine

I have repeatedly running into this issue where the latest mangOH Virtual Machine’s Developer Studio application gets corrupted or something.

Three times now I have reinstalled the VM from scratch and tried to continue my development in Developer Studio, only to have it crash with a Java runtime error, and then Developer Studio never launches again.

Restarting the VM fully doesn’t fix it, only reinstalling the VM from scratch as far as I’ve been able to tell.

I imagine maybe there is a repair tool or some sort of incompatibility I am experiencing that you may be able to help troubleshoot.

The VM I downloaded is the current one on the Sierra Wireless website:

I tried executing the devstudio executable within the devstudio directory, because I thought maybe just the shortcut was broken, and it still didn’t work.

I did however see the output of my attempted execution from the terminal, and located the error log file that was generated, I have attached it.

If anyone has any ideas about how to resolve this repeated behavior it would be much appreciated.

developer_studio_error_log.txt (992.3 KB)

Hi @cmccarthy

will give a try in this VM ASAP.
In the meantime: when you say you’re reinstalling the VM from scratch, how are you resuming your dev?
Are you somehow persisting the full workspace, and reuse it from an install to another?
(if yes, this won’t help if the problem comes from a corruption in the workspace (already seen this kind of eclipse bug…))

ok, got it.
It looks like all the requirements were not installed in the VM.

I got it running good by:

It should probably help.

Great I will try that :slight_smile:

And no I was not persisting the workspace, as I figured that was the case.

I was just cloning my source codes fresh via git on each install (and syncing whatever changes I had made before trashing the corrupted VM obviously).

I’ll let you know how it goes when I have the chance to try out your suggestion later today.

Forgot to reply earlier, but what you suggested worked :slight_smile:, thank you very much.

1 Like