Legato Hangs when attempting to connect or compile


#1

I have been trying to use the latest version of Legato (downloaded Nov 3 2016) but have been having issues. When I attempt to create the connection to the mangOH board the Developer Studio locks up. The only way out is to either kill the process or to shutdown the VM. I have attempted to increase the resources to 4GB of ram for the VM but still no success. Without this I cot upload any samples to the board.

Any help would be great.
Kas


#2

There is a known issue in the delivered VM: DS shouldn’t be launched through the shortcut provided on the launcher.
Just run it directly with the $HOME/legato/devstudio executable and it won’t hang anymore.


#3

I’ve just started using the Legato VM and I had the same problem, it always just hung and you’d have to kill or shut down. Changing the file permissions seemed to fix it and make the problem go away completely; by default some of the permissions are read only and not read/ write. Although I’m sorry to say that I already can’t remember exactly which permissions I changed; I think it was for the executable. :grin:


#4

Thank you that worked, now if we could just figure out which permissions need changing to use teh quick launch that would be great.

Kas