Red_wp85 failed to install on mangOH Red with WP7502


#1

Hello,

I am using WP7502. I have followed the steps from getting_started document to build red_wp85 (which is supposed to be for both wp75 and wp85 modules). The installation went ok (ended with “SUCCESS”). After logging in to mangOH Red board, I could see the build applications gpioExpanderServiceRed, mgttClien and redSensorToCloud. However then the board restarts and all the newly build applications are wipped out.

I have tried to install the mangOH_Red.wp85.update package using instsys and instapp commands, the results are the same.

Is that anything that I am missing? I have done all the steps from getting_started guide prior to the red_wp85.

Regards,
T.


#2

Hi

Have a look at the console logs to see if an application is repeatedly crashing, If yes, then the system will roll back to the last good system if there are multiple crashes withing a probation period. http://legato.io/legato-docs/latest/basicUpdates.html

Have you tried posting on the mangOH forum https://forum.mangoh.io/? he mangOH team is more active on that forum.

Regards
A


#3

Please try to build red_wp750x for WP7502 module.


#4

Hi @TomaszB ,
Which version of legato version you are suing to build the red_wp85?
redSensorToCloud and other few Apps will not work with legato-16.10.3 and legato-16.10.4, When we tried with legato-17.08.1 on top of firmware Release 15 of WP85, redSensorToCloud app started running and we were able to see device was connecting to cloud(airvantage).

Please try with legato-17.08.1 version.

Also if you are using Wp7502 module, Use “make red_wp750x” to build the update file as told by JordanZhao.

Regards,
Muralidhara N.