18.03.0 Legato Framework update on MangOH Red


I’m trying to update the legato framewrok on the MangOH red with a WP7502.
After having built the latest (18.03.0) framework I ran “instsys system.wp750x.update”.
I then connected via ssh to the board and issued a “legato version” command.
At first it showed the old legato version (16.10.3) but after a few “legato version” commands it started showing the 18.03.0.
However after a few seconds the board rebooted and when it came back up again, the old legato framework version (16.10.3) appeared as installed.

I also tried using the “instlegato” tool, with the same outocome.

Thanks for your help

I think the yocto version is not matching with this legato version 18.03 as you can see from here:


Your yocto version is matching only with legato 16.10.4.

I have version 15 with legato 18.03 on Wp8548. if you have a fault with the build and it fails to run it will revert to base system… Watch the log output then update legato. This will help find error make sure you running the same yocto as toolchain you build legato with.

Me too, we need to make sure the Legato Framework is well built without ERROR.
root@swi-mdm9x15:~# cm info
Device: WP8548
IMEI: 359377060004677
FSN: LL537500080903
Firmware Version: SWI9X15Y_07.12.14.00 r34472 CARMD-EV-FRMWR1 2017/11/29 18:24:42
Bootloader Version: SWI9X15Y_07.12.14.00 r34472 CARMD-EV-FRMWR1 2017/11/29 18:24:42
MCU Version: 002.004
PRI Part Number (PN): 9904889
PRI Revision: 01.05
Carrier PRI Name: GENERIC
Carrier PRI Revision: 001.034_000
SKU: 1102621
Last Reset Cause: Unknown
Resets Count: Expected: 0 Unexpected: 0
root@swi-mdm9x15:~# legato version