Make red_wp85 gives error of missing file wifi.sinc

I want to install legato framework and compile code for wp7610 mangOH red board. can anyone please help me for step by step guide ? Which toolchain need to install and which version of mangOH needed ? i have followed step by step guide as per Install the Application Framework - Legato Docs . but i am not getting success. Thanks in advance.

Why are you using red_wp85 for wp76 module?

I have tried make red_wp76xx too.
still getting same error .

Can you pleas specify which steps needed to build complete code of legato and mangOH? i am using linux 18.04

You can see here

For downloading the toolchain, you can use LEAF tool to download or you can directly download from

For example, this is for FW R13:,-d-,1-components/#sthash.RJZAl6v3.dpbs

I don’t want to upgrade on board . i just need to compile that code in my system . I have gone through your given link but not getting success same error occurred . i am trying for wp85 as per the document. Have you tried to build if yes please let me know the exact steps from installing toolchain of legato . version of toolchain etc…so that i can start from scratch again…

what is the reason you cannot upgrade FW?
Of course you cannot use wp85 as your are not using WP8548 module, the document is just giving an example to you.

There is no official released FW that is using legato 18.4.0.
You can check in

I don’t have any board with me but we are sure we will use wp7610 module. but i am not experimenting that as we have example of wp85 code. i am new for legato and mangOH as well so it will be helpfull if i get exact same for building firmware for mangOH and legato framework using make wp85 and make red_wp85 for mangOH.

as said before, there is no official released FW that is using legato 18.4.0.
Not quite sure what FW are you using now…

I am using
toolchain :
mangOH : git clone --recursive GitHub - mangOH/mangOH: Primary mangOH git repository
legato : git:// -m legato/releases/17.07.1.xml

this is not making sense, you are using legato 18.4 but you download version 17.07.1

I am not using legato 18.04 . that is my linux pc’s version of linux
I am following this link for setup Install the Application Framework - Legato Docs
and 41110479-80-81-82 PrepMangoh

if you are just trying to compile but not going to download to the board, why are you choosing a version that is so old?

Anyway, what is the problem now?

can you help me to solve this out step by step ??? I have tried with newer version too.

I am not sure if the latest mangoh source can be compiled by an very old legato version.

Not compiling make red_wp85 it is giving error egato_framework/legato/modules/WiFi/wifi.sinc’ not found.

Are you compiling the mangoh source or legato framework?
Can you paste more error message?

mangOH source . I think legato source is compiled for wp85 see the logs below

Print some diagnostic messages.

== built system’s ==
cat build/wp85/staging/system/

Check PA libraries.

checkpa wp85 || true
Checking PAs
cat: legato_framework/legato/build/wp85/pa-check/pa-name-list.txt: No such file or directory
install targetFiles/shared/bin/start build/wp85/staging
mklegatoimg -t wp85 -d build/wp85/staging -o build/wp85
Using fakeroot /usr/bin/fakeroot …
-t wp85 -d build/wp85/staging -o build/wp85
Target: wp85
Input: legato_framework/legato/build/wp85/staging
Output: legato_framework/legato/build/wp85
wp85: Generating the framework image (yaffs2)
wp85: Generating the framework cwe (yaffs2)
wp85: Generating the framework image (squashfs.ubi)
wp85: Generating the framework image (squashfs)
wp85: Generating the framework cwe (squashfs.ubi)

make red_wp85
Makefile:86: ==== OCTAVE_ROOT not defined ====
Not building LEGATO due to $LEGATO == 0

NOTE: When using leaf, these TOOLCHAIN_X variables don’t need to be passed to mksys.

mksys -t wp85 --cflags=-O2 --object-dir=build/red_wp85 --output-dir=build/update_files red.sdef
mangOH/shared.sdef:11:48: error: File legato_framework/legato/modules/WiFi/wifi.sinc’ not found.
Makefile:115: recipe for target ‘red_wp85’ failed
make: *** [red_wp85] Error 1

Maybe you can try a newer legato version, I just have a look on legato 19.11.0, I can see the wifi.sinc file.