Legato Hierarchy View Disappear

Hi all!
I am working on the latest version of legato for FW16 16 and all the apps work! (I also tried on the board!) But I still have a problem: when I run GPIO and MUX apps, the Legato Hierarchy View disappears and this problem occurs (also if on the board all works):

To help you to understand, here is my project’s dependancies:
mySystem.sdef:

shared.sdef:

I don’t understand where I’m wrong. Do you think this could be a dependancies problem ?
With this problem I’m limited to adding and removing apps from my Legato, so I don’t have full control over my project. But the good thing is that it even works on the latest version of Legato !!! :grin:

for adding and removing apps, you should modify the .sdef.

yes, I can add them in the apps of sdef, but I would see them also in the lateral hierarchy view and this doesn’t happen :frowning:

it does not affect to build the image, right?

I have the same problem, the hierarchy view has disappeared and I have no idea how to get it back. I think it happened after I deleted a test app from the Legato view but can’t recall for sure. Are you saying the Legato view simply doesn’t work so don’t use it?

On the topic of VS Code I notice the extension has not been updated in a while, also that the forum category for it is not exactly a hive of activity. The extension documentation states “We welcome feedback and want to know what features are important for our users” yet this issue was reported quite a while ago ( Hierarchy View Disappeared ) with apparently no resolution. It also says components are coming in the next release - this seems like an essential feature but that comment was over a year ago. Does anyone know if there are updates in the works or if Sierra is still supporting and actively working on VS Code integration? Should we even be investing the time in using it or is it basically stillborn?

If they’ve effectively deprecated it it would be good to know.

Are you able to build the image?

Yes, although haven’t been able to do anything useful beyond that at this point (like debug) as we are getting errors about missing headers such as interfaces.h and legato.h and don’t know why.

I’d still like to know if Sierra is working on the VS Code plugin before heading down a rabbit hole- are you with Sierra and if so are you able to answer that?

I think so, here says it is the IDE for legato

https://docs.legato.io/latest/tools_vsCode.html