Legot Build : The task provider for ""

Hello

I’ve just install vscode 1.46.1, legato plugin 1.2 and leaf 2.3 on my ubuntu 20.04.

When i try to compile, i’ve always a task error with the message :
The task provider for "" tasks unexpectedly provided a task of type "Legato Build".

Other problems :
when I try to remove component, only the sdef file is update but the legato view a empty removed component.

1 Like

@Ph38240, you are trying to compile what? a Legato app or system?

This message happen when I use “legato: build” or “legato: build and install” after press shift+ctrl+b

The legato plug-in make a system build “mksys”.
The build is OK, but a have the error message.

Now I use the command line in a separate shell to make just the application build ( I don’t know how to make a application build in vscoder with the plug-in

@Ph38240, to just build the app you need to change and to select the app .adef file in the .xdef menu (bottom blue bar), as is explained here: https://docs.legato.io/latest/tools_vsCodeDefinition.html

Ok, but i’ve always the error message

Having the exact same problem on:
VS Code 1.47.1, legato plugin 1.2 and leaf 2.3 runing on Ubunto 18.04

Now, i’ve just install the latest VsCode 1.17.2
The message is always present and now the legato: hierarchy view is empty !

I uninstall legato plugins and install , but nothing

To be more precise, the message from stack " The task provider for "" " come when i just press ctrl + shift + b key and the build drop down showing !

@Ph38240, To well understand, the build action worked well, but you get just this error message, right? I think it will disappear by relaunching vscode.
About the legato: hierarchy view, I agree it doesn’t work well for the moment, what you want to do with legato: hierarchy view you can do it with workspace explorer section.

I reinstall all (leaf vscode plug-in) tree times, but the error alway appeared.
The hierarchy is for managing ccomponent/app…

I could not reproduce the problem, here is my setup:
VScode Version: 1.47.2 | Legato Plugin : 1.2.0 | LeafMinVersion": “2.3.1” | OS: Linux x64 5.3.0-61-generic - Ubuntu 18.04.3 LTS | wp76 R13.3 package

Here’s my system setup:
VsCode Version: 1.47.3 Date: 2020-07-23T15:51:39.791Z
Plugin legato : 1.2.0
OS: Linux x64 5.4.0-44-generic - Ubuntu 20.04.1 LTS
Leaf version 2.3.1
Legato Package :

  • swi-wp77_3.4.0 - SDK for WP77 (Release 12 + Legato 20.04.0)
  • swi-vscode-support_200624 - VS Code features support for legacy SDKs

Even with your setup i could not get this message, can you describe more what you have done (steps) please?

Hy mehdiALL1

It’s very simple, I follow exactly the tutorial on doc.legato.io (https://docs.legato.io/latest/tools_vsCodeInstall.html).

Yes, I know how to do it … don’t know what is the cause of this message… but at least you are able to build successfully … so you are not blocked

Just started running into the same issue: legato: hierarchy view completely empty.

Worked fine yesterday at the end of the day when I shut it down -> today it is completely empty!

Been running through every element of the settings and config and all appears to be in order.

Thoughts?

Hi @mpetersen … this issue (legato: hierarchy view) has already been reported internally … I’ll update you here :

Thanks mehdiALL1,
I will try to wait patiently for your update.

Mike

The root cause being an issue in either the sdef, or adef, or even file structure. The parsing is so strict that any error or misconfiguration prevents the view from loading.
If the view is already loaded, it will show statically until the next time it is reloaded (most likely when vscode is reopened).
We will bring up this and other high priority bugs to see if we can plan for a release…

@mehdiALL1

Appreciate the update. Can you list any of the “syntax” or “structural” items that you’ve identified to date that result in View loading failure? Is it a true statement that removal of the culprit App will re-enable the View to load?

Thanks