mangOH project support

When I use vsCode Legato extension for my mangOH yellow project I can’t use Legato: Hierarchy view, because it’s empty. I have a feeling that current version of the extension doesn’t support mangoH project. Is there a way to make it work?

@Pawel,

The Legato: Hierarchy view, was there and it becomes empty or it’s never displayed your system? there are some complaints with this Hierarchy view in this forum, but I don’t think it s related to the Mangoh Yellow project

About the Mangoh Yellow project why you have this feeling? as long as the mangoh yellow package with Leaf it should support also with vscode

Hierarchy view is always empty no matter what I try to do. Even if i change it to other .adef or .sdef. Also I found out that I can’t choose default.sdef - so I think there is some visibility problem.

I am currently working on mangOH red and problem is the same that I had with mangOH yellow. In the picture you can see errors that I had when I changed to red.sdef.

My feelings about vsCode not supporting mangOH (red and yellow), are because of problems mentioned here (hierarchy view) and problems that I mentioned here: Legato extension overwrites .vscode/c_cpp_properties.json

Actually the problem with overwriting c_cpp_properties.json is more important to me. I had to disable vscode-legato extension because of that.

PS: build and install command works OK.

@Pawel, About the legato: hierarchy view, I agree it doesn’t work well for the moment, but, what you want to do with legato: hierarchy view you can do it with workspace explorer section.

Also I found out that I can’t choose default.sdef - so I think there is some visibility problem. >> Yes, the only default.sdef file that you can use is the one linked to your leaf package, I’m not sure if you can choose another.

About what you want to do with both mangoh’s, have already tried it with a simple module package? (wp76, wp77…), just to confirm that the issue is linked to the mangoh’s pack.

Yes, I have already tried those simple packages. There is the same issue.

Ok, About the problem with overwriting c_cpp_properties.json, I’ll check internally if it’s a known behavior and if we can do something (the update will in Legato extension overwrites .vscode/c_cpp_properties.json)