[LEAF] Attempt to add package fails

Any attempt to add any package to profile fails. Below is a log of setup process using VsCode. The same happens when running manually. Looks like remotes is out of sync. BTW, the same process worked few days ago (on 27/3).

> Executing task: leaf --non-interactive setup -p swi-wp76_4.0.0 profile_wp76_3.0.0 <

Cannot find workspace, initialize one in /home/sashag/a2_workspace? (Y/n)
  -> Execute: leaf init
Workspace initialized /home/sashag/a2_workspace
  -> Execute: leaf profile create profile_wp76_3.0.0
Current profile is now profile_wp76_3.0.0
Profile profile_wp76_3.0.0 created
  -> Execute: leaf profile config profile_wp76_3.0.0 -p swi-wp76_4.0.0
  -> Execute: leaf profile sync profile_wp76_3.0.0
Profile is out of sync
Packages to install: wp76-legato_19.02.0-201903211732, wp76-toolchain_SWI9X07Y_02.28.03.01-linux64, wp76-modem-image_13, wp76-legato-image_19.02.0-201905270349, wp76-linux-image_SWI9X07Y_02.28.03.01, wp76-image_4.0.0, swi-legato_1.4.191225, swi-wp76_4.0.0
Total size: 401.2 MB
Do you want to continue? (Y/n)
[100%] Downloading 25fef75-swi-license_1.1.leaf 
  Profile provisioning interrupted
  Error while installing required packages (The file /home/sashag/.cache/leaf/files/25fef75-swi-license_1.1.leaf hash could not be verified, expecting sha384:25fef75b05b56102935be2083d8e7ff0351b80e6b62675a2238afc4cd00b410a9ebf870a69128dcddcc6bef386e06fcf but was sha384:3a1a6d06e6c834a632fee34549b7bb68b98fe3bf9909b4f6c23c8cf0c4750bac9725f5bace3c7a89e05f7af17ddd41be)
  try to download the file again, or contact the package owner
  try leaf profile sync to resume
Command exited with 2
  Sub command failed: 'leaf profile sync profile_wp76_3.0.0'
The terminal process terminated with exit code: 2

Terminal will be reused by tasks, press any key to close it.


I have the same problem.

I had the same problem. Sierra had a problem with their download servers and the packages were all screwed up. They fixed it around April 1st.

hi @zuuuuk, @Sasha,
is your issue solved?
can you download properly the package?

Yes, seemingly it was solved, thanks.