Unknown Package wp77-legato_21.05.0-202110290357

I’ve been having some issues trying to switch to the swi-wp77_6.0.1 leaf profile so I’ve done a clean install of everything.

I’m using WSL on windows with Ubuntu 18.04, i’ve run the following commands from a clean install before opening Visual Studio Code

sudo apt update
sudo apt upgrade
sudo apt install python3-dev
sudo apt install subversion
wget https://downloads.sierrawireless.com/tools/leaf/leaf_latest.deb -O /tmp/leaf_latest.deb && sudo apt install /tmp/leaf_latest.deb
svn co "*redacted*" ./gwy

Then in visual studio code i installed the extensions for legato, opened the leaf tab and selected ‘add to profile’ to the swi-wp77_6.0.1 package, and then goet the following error:

Executing task: leaf profile config --add-package swi-wp77_6.0.1 SWI-WP77 && leaf --non-interactive profile sync SWI-WP77 

  Unknown package wp77-legato_21.05.0-202110290357
  check available packages with leaf search

 *  The terminal process "/bin/bash '-c', 'leaf profile config --add-package swi-wp77_6.0.1 SWI-WP77 && leaf --non-interactive profile sync SWI-WP77'" terminated with exit code: 2. 
 *  Terminal will be reused by tasks, press any key to close it. 

After trying some things in the Leaf commandline, e.g. leaf search, leaf profile switch and leaf profile sync which all gave similar issues. I then tried adding swi-wp77-wp77_5.0.1 this worked correctly, so i tried adding the 6.0.1 version again and this kept failing with the ‘unknown package’ error.

What am I doing wrong here?

I don’t see problem to use leaf shell with “swi-wp77_6.0.1”
are you using ubuntu 16?

I’m using Ubuntu 18.04, and if I’m trying it now I’m getting that error, I know it has worked in the past.

What swi_vscode_support version are you using?

I’m using the ‘add to profile’ button to add it:

I haven’t added any swi-vscode-support to my project.

When trying to add swi-vscode-support_200624 i’m getting this popup:

Can you try in ubuntu 16?
(Can do this in virtual machine)

I’ve done the following steps:

sudo apt update
sudo apt upgrade
sudo apt install python3-dev
sudo apt install subversion
wget https://downloads.sierrawireless.com/tools/leaf/leaf_latest.deb -O /tmp/leaf_latest.deb && sudo apt install /tmp/leaf_latest.deb
svn co "redacted" ~/gwy
  • Installed following plugins:

  • in Leaf tab on swi-wp77-6.0.1 clicked ‘Add to profile’

This gave me the following result:

When using leaf search I can find it in the list of available options:

You only tried in WSL? Not sure if it works in WSL …
I would suggest you try in virtual machine or real ubuntu pc.

Can you import swi_vscode _support?

I do not currently have access to a virtual or real machine running Ubuntu, however I have had at least the download part work previously in vscode in the past. I can probably attempt this tomorrow.

In the current version however I still get this error after adding the vscode support 200624:

Is it possibly for you to attempt to do what i’ve done from a blank instance? Either VM or otherwise?

just tried that on Ubuntu 16 real PC, no problem is found:

> Executing task: leaf --non-interactive update --add-package swi-wp77_6.0.1 <

Do you want to add package swi-wp77_6.0.1? (Y/n)
Profile is out of sync
Packages to install: wp77-modem-image_15.1, wp77-legato-image_21.05.0-202212280324, wp77-linux-image_SWI9X06Y_03.00.13.00, wp77-image_6.0.1, swi-wp77_6.0.1
Total size: 115.7 MB
Do you want to continue? (Y/n)
Run sync steps for swi-aptdeps-image_1.0
Run sync steps for swi-license_1.2
Run sync steps for swi-verify-aptdeps_1.7.210909
Checking required apt packages..

It is recommended to have the latest version of swiflash swicwe 

  sudo apt-get update && sudo apt-get install --upgrade -y swiflash swicwe 

Do you want to execute this command (Y/n)? n

Skip update for swiflash swicwe . Problem may happen during package installation due to the out-of-date version.
All system dependencies are OK
Run sync steps for swi-verify-license_1.4.190813
License already accepted: sierra-v1
Downloading 5 package(s)
[1/5] Installing wp77-modem-image_15.1
[2/5] Installing wp77-legato-image_21.05.0-202212280324
[3/5] Installing wp77-linux-image_SWI9X06Y_03.00.13.00
[4/5] Installing wp77-image_6.0.1
Run install steps for wp77-image_6.0.1
Generating device image: 9999999_9907618_SWI9X06Y_02.36.08.09_00_GENERIC_001.079_000-full.spk
Generating device image: 9999999_9907787_SWI9X06Y_02.36.06.00_00_ATT_001.067_005-full.spk
Generating device image: 9999999_9908088_SWI9X06Y_02.22.12.00_00_VERIZON_001.042_004-full.spk
Generating device image: 9999999_9908397_SWI9X06Y_02.36.08.02_00_TELSTRA_001.061_001-full.spk
Generating device image: 9999999_9908788_SWI9X06Y_02.36.08.09_00_SIERRA_001.049_000-full.spk
[5/5] Installing swi-wp77_6.0.1

Terminal will be reused by tasks, press any key to close it.

I am using this swi_vscode_support version:

I installed virtualbox, installed Ubuntu 18.04 (downloaded from their server), did the setup, but still have the exact same issue:

Was the install you did on an existing system or a clean install?

It is on existing machine

I found that it cannot find the legato package

Can you install the fx30 catm package with same legato version?

I remember my pc has installed the fx30 catm package before

Gives the same result unfortunately, could it be that the download link is currently broken and that because you have installed it previously it doesn’t attempt to download?

oh wait it still had the 6.0.1 in it, I have now removed it and it looks like it is doing something.

I have run it now, the swi-fx30-catm_4.2.0 did manage to install correctly, however now switching back to swi-wp77_6.0.1 is still not working with the same ‘unknown package’ error

Is it ok to download and install swi-wp77_6.0.0.beta ?

I have zipped my folder as wp77-legato_21.05.0-202110290357.tar.gz
you can download it and extract to /home/owner/.leaf and see if it works

That worked but only in a virtual machine, when used in WSL it runs into a ‘too many redirects’ error and then the build will fail after.

Is it ok to download and install swi-wp77_6.0.0.beta ?
no idea on WSL (seems it does not support symbolic links?)
probably you need to compile in virtual machine or real linux PC