Mkapp build fail (ninja: error: missing)


I would like to use Legato with MangOH Red board, but I’m unable to compile sample app helloWorld. I started on fresh Ubuntu LTS (tried both 18.4 and 16.4), followed Leaf installation instructions and set up profile as:

> leaf setup -p swi-wp76_4.0.3 wp76stable
Cannot find workspace, initialize one in /home/xxx/myWorkspace? (Y/n)

  -> Execute: leaf init
Workspace initialized /home/xxx/myWorkspace
  -> Execute: leaf profile create wp76stable
Current profile is now wp76stable
Profile wp76stable created
  -> Execute: leaf profile config wp76stable -p swi-wp76_4.0.3
  -> Execute: leaf profile sync wp76stable
Profile is out of sync
Packages to install: wp76-legato_19.02.0-201903211732, wp76-toolchain_SWI9X07Y_02.28.03.05-linux64, wp76-modem-image_13.3, wp76-legato-image_19.02.0-201908300809, wp76-linux-image_SWI9X07Y_02.28.03.05, wp76-image_4.0.3, swi-wp76_4.0.3
Total size: 478.4 MB
Do you want to continue? (Y/n)

Run install steps for swi-license_1.1
Run install steps for swi-verify-license_1.4.190813
Run install steps for swi-aptdeps-legato_1.0
Run install steps for swi-verify-aptdeps_1.5.190813
Run install steps for swi-license_1.2
Run install steps for swi-aptdeps-image_1.0
Run sync steps for swi-aptdeps-image_1.0
Run sync steps for swi-aptdeps-legato_1.0
Run sync steps for swi-license_1.1
Run sync steps for swi-license_1.2
Run sync steps for swi-verify-aptdeps_1.5.190813
Checking required apt packages........
All system dependencies are OK
Run sync steps for swi-verify-license_1.4.190813
License already accepted: sierra-v1
License already accepted: sierra-v1
Downloading 7 package(s)
[1/7] Installing wp76-legato_19.02.0-201903211732
Run install steps for wp76-legato_19.02.0-201903211732
[2/7] Installing wp76-toolchain_SWI9X07Y_02.28.03.05-linux64
Run install steps for wp76-toolchain_SWI9X07Y_02.28.03.05-linux64
Configuring the toolchain for your environment, this may take a few minutes...
[3/7] Installing wp76-modem-image_13.3
[4/7] Installing wp76-legato-image_19.02.0-201908300809
[5/7] Installing wp76-linux-image_SWI9X07Y_02.28.03.05
[6/7] Installing wp76-image_4.0.3
Run install steps for wp76-image_4.0.3
Generating device image: 9999999_9907152_SWI9X07Y_02.28.03.05_00_GENERIC_002.073_000-full.spk
Generating device image: 9999999_9908043_SWI9X07Y_02.28.03.05_00_TELSTRA_001.058_000-full.spk
Generating device image: 9999999_9908843_SWI9X07Y_02.28.03.05_00_DOCOMO_001.024_000-full.spk
Generating device image: 9999999_9908844_SWI9X07Y_02.28.03.05_00_SOFTBANK_001.028_000-full.spk
Generating device image: 9999999_9908845_SWI9X07Y_02.28.03.05_00_KDDI_001.026_000-full.spk
[7/7] Installing swi-wp76_4.0.3

Note: Output says “License already accepted” because I deleted profile and tried again.

Then I copied sample app helloWorld into workspace folder, activated leaf environment using

> leaf shell
Leaf Shell /bin/bash started in Leaf environment.

(lsh:wp76stable) > cd helloWorld/
(lsh:wp76stable) > mkapp -t wp76stable helloWorld.adef
ninja: error: '/home/xxx/myWorkspace/leaf-data/wp76stable/wp76-legato/build/wp76stable/framework/lib/', needed by '/home/xxx/myWorkspace/helloWorld/_build_helloWorld/wp76stable/staging/read-only/lib/', missing and no known rule to make it

It’s possible that I missed something terribly obvious, but right now I’m at a loss what to do.


Try this “mkapp -t wp76xx helloWorld.adef”


Hi Tom,

thanks, that did the trick!

Have a nice day.