WP7502 problem with communicate to SIM card


I am using Mango green board and WP7502 for now, legato version 16.07.

My problem is that after I connect to legato through ssh, I can do all the “read” operations such as “cm info”, “cm data”, “cm sim” or some other commands. But if I want to unlock the SIM card through “cm sim enterpin xxxx” or connect to internet through “cm data connect &”, ssh crashes and reports the error “Connection to port 22: Broken pipe”.

What I have tried:

  1. I tried to connect through linux and window systems and they get the same problem, which I guess the problem is not from my system settings.
  2. If I put the SIM card to my smartphone, it works fine, and I am sure SIM’s APN setting is correct in legato.
  3. One month ago, everything is working.
  4. I want to reset the legato system, but I do not know how. If I enter “fwupdate download FILE”, it said “FILE” is not found, if I enter “fwupdate query”, it said " can’t connect to service; is fwupdateService running?".

Can anyone help me with this problem?

Thank you very much!

Hi @smoothie0000,

that looks a bit weird, it would be nice if you can provide some logs by observing the UART console.
I’m assuming that some logs would be printed when it crashes.

A weird but possible thing is that you might be connected through USB, and when it starts to establish a connection, it needs more power than your port can supply and reboots. Could you try to power it through a powered USB hub or using a power supply to see if that’s the case?

Finally, I would highly recommend that you update to the latest firmware (Release 14 w/ Legato 16.10.3).
You can get it here: https://source.sierrawireless.com/resources/legato/wpfirmwarerelease/

1 Like

HI CoRfr,

Thanks for the reply! You are right! Power is the problem, after I used a 12V power supply, everything works!

Thanks! I would update the firmware.