Cellular Service Unavailable on WP7504

Hi everyone,

I’ve been having an issue with my WP7504 module. I cannot place any calls from it, nor can I connect to data with the cm data connect command. Some info below.

– WP7504 firmware: SWI9X15Y_07.12.14.00 r34472 CARMD-EV-FRMWR1 2017/11/29 18:24:42
– Legato version: 18.05.1_d037d454a5d7c4f01c1fe847eb476b4a_modified

– The carrier I’m using is Red Pocket on their GSMT network (T-Mobile).

– I have another device with a WP8548 module. The SIM card works right off the bat with this module. This device has a firmware version of SWI9X15Y_07.12.09.00 r34123 CARMD-EV-FRMWR1 2017/04/26 23:34:19 and a Legato version of 17.11.0_b38d0471377413f96cb09b3588d5a8c2_modified.

– I have configured the WP7504’s APN with the information they provided (APN is wholesale). I have tried both IPV4 and IPV4V6 for the PDP type. Interestingly enough, the WP8548 is configured to use att.mvno for its APN (not what the carrier specified), and it doesn’t cause any issues.

– I have tried calling my personal phone number from the device via the AT command ATDnnnnnnnnnn;, but it merely outputs “ERROR.” This works fine on the WP8548.

The cm radio command outputs the following information:

Power: ON
Current Network Operator: RED POCKET
Current RAT: LTE network (LE_MRC_RAT_LTE)
Status: Registered, home network (LE_MRC_REG_HOME)
Signal: Very strong signal strength (5)
PS: Packet Switched Registered, home network (LE_MRC_REG_HOME)

The cm data command outputs the following information:

Index: 1
APN: wholesale
PDP Type: IPV4
Connected: no

The cm data connect usually outputs the following result:

Setting up profile 1
Setting access point name ... ok
Setting packet data protocol ... ok
Setting Authentication ... ok
Connecting ... ok
Checking if device 'rmnet0' is up ... ok
Routing inet ... failed
Fri Jun 29 19:25:54 UTC 2018 - RTNETLINK answers: Network is unreachable

… although sometimes it outputs this instead:

Setting up profile 1
Setting access point name ... ok
Setting packet data protocol ... ok
Setting Authentication ... ok
Connecting ... failed
Fri Jun 29 17:59:27 UTC 2018 - Connection Failure: LE_FAULT

I’m a little confused at this point what the root of the issue is. Any help would be greatly appreciated. Thank you very much in advance, and please let me know if I should provide any more information!

HI coffeebean,
the main difference between the two modules WP7504 and WP8548 , is that the first one supports LTE/UMTS/CDMA whereas the second supports UMTS/GSM/GPRS.
in your log we can notice that the WP7504 is registered into LTE , but can not connect the data session using CM data connect .
There is a known issue with this module in LTE using cm data connect; this issue will be solved into the next release of Legato.

my suggestion, to work as the WP8548, is to force the WP7504 into UMTS by using the following command:

cm radio rat UMTS

in that technology you should be able to do data connect .

Regarding voice call, you can check , in which technology the module is when you perform call, with the WP8548 : UMTS or GSM.
if it is UMTS, it should be possible to do the same with WP7504. if it is in GSM, you could verify that your network allow voice call in UMTS and do a try.

let me know
best regards