Problems upgrading to 14.10


#1

Hello,

I’ve been trying to get 14.10 working on my WP7100 with the red dev-kit. After the upgrade, I haven’t been able to connect to the cellular network.

Observations:
[ul]

[li]Running ati returns a correct value. Running at!gstatus? shows me as being in low power mode.[/li]
[li]The command at!unlock=“A710” returns ERROR; therefore, I am unable to run at!gobiimdisabled=1 to change to ONLINE.[/li]
[li]Using the cm utility:

[code]root@swi-mdm9x15:~# cm sim
SIM card is inserted and unlocked (LE_SIM_READY).

root@swi-mdm9x15:~# cm radio
Current Network Operator:
Status: Not registered and not currently searching for new operator (LE_MRC_REG_NONE)
Signal: No signal strength (0)

root@swi-mdm9x15:~# cm radio on
root@swi-mdm9x15:~# cm radio off
Radio power is already set to OFF.[/code]
[/li]
[li]The Ethernet port no longer works[/li]
[li]Running [i]at!custom?[\i] returns:

!CUSTOM: ISVOICEN 0x01 CMCLIENT 0x01 ADBENABLE 0x01 GPSENABLE 0x01 RRCREL7CAPDIS 0x02 GPSSEL 0x01 NMEAENABLE 0x01 GOBIIMEN 0x01 [/li]
[li]Probably unrelated, but the SD Card is also non-functional.[/li][/ul]

I’ve noticed a couple of people in the forums have had similar problems in the past, but none of their solutions have worked for me. Any help would be appreciated!

Thanks,
– Kevin


#2

Hi Kevin,

I will need you to do the following before we can proceed.

    1. Run at!openlock? (This will return a string, copy and paste that string to me through PM). With this string, I will generate a code for you.
    2. Once you receive the code from me (through PM), run at!openlock="code".
    3. Then run at!setlock="A710"
    4. Now reset your module

You should now be able to run at!unlock=“A710”.

    1. Run at!gobiimdisabled=1 to turn the modem back up.
    2. Run at!custom="HSICENABLE",1 to enable the ethernet interface.
    3. Restart again and everything should be back up.

Enoch


#3

Hi Enoch,

I got the exact same problem like Kevin.
After the update of my Development kit AirPrime to 14.10, the command at!unlock=“A710” gives me an ERROR.
Maybe you can help me too?

Thanks a lot.

Best regards,
Markus


#4

Yes of course, please send me a PM with the required information.


#5

Just a heads-up to anyone sending Enoch a reply: don’t power down your device or re-run at!openlock?. It generates a new string each time the command is run, and you’ll have to re-send him the string.

My modem/Ethernet port was fixed after this though! Thanks Enoch!