Legato extension overwrites .vscode/c_cpp_properties.json

Is there any way to stop legato extension from overwriting the .vscode/c_cpp_properties.json file? I want to extend includePath, so that my headers are visible to the VScode, but every time I restart vs code settings file gets ovewritten. Or maybe there is other way to include files (I mean, only for inteli Sense and editor’s warning suppression, not compilation)?

Also, how to stop vsCode from highlighting #include “interfaces.h”, as a “can’t find file” warning? There is no permament path to this header file.

I currently use Legato extension v1.2.0 and VS code version 1.47.2.

EDIT: About the second problem: when I try to compile project via ctrl + shift + b -> legato: build, I see that legato adds build location to include files, so that warning about interfaces.h is solved. It means my problem is connected with other thread mangOH project support

@Pawel, this is happening in the same project? or in the separate cpp project? more details, please

All of my issues are happening in every project I have with legato extension enabled.
It is not a problem with my project. It is a problem with legato extension in general.

@Pawel, this issue has already been reported internally … I’ll update you soon

cc: @lpacyk