Failed to build yocto/WP76xx Firmware Release 10.1


#1

ERROR: time-genoff-git-r0 do_fetch: Fetcher failure for URL: ‘file://time-genoff-bin.tar.bz2’. Unable to fetch URL from any source.


#2

We tried with latest release 10.1 by compiling and building wp76xx yocto it is working fine.
We think in this case of error what you are facing is because of not mentioned the module in “PROD” of Makefile/external.mk as below, please update the external.mk file and compile once again.
MACH ?= mdm9x28
ifeq ($(PROD),)
PROD = wp
So, We suspect that is the cause. Although we checked Makefile/external.mk in latest release which we downloaded it is updated by
“PROD = wp” or “PROD = ar758x” .We downloaded distro from source.sierrawireless.com. May i know how did you downloaded distro (yocto).


#3

The error happens when is compiled under environment:

export NUM_THREADS=1 BB_NUMBER_THREADS=1 PARALLEL_MAKE=–jobs=1

It look there is a broken dependency and race condition, which usually passes on concurrent compilation and fails on serial.
Better to fix it and add serial compilation to regression check.


#4

We tried with similar enviornment as mentioned “export NUM_THREADS=1 BB_NUMBER_THREADS=1 PARALLEL_MAKE=–jobs=1”.
It can able to compile.May i know requirement of setting up this enviornment.
for your info We are using ubuntu 16.04.please check in ubuntu 16 if using other than ubuntu 16.


#5

make -C yocto # <— fails because PWD is used instead CURDIR

cd yocto; make # <-- works


#6

Yes,
We need to go inside yocto and give make


#7

How can I submit patches / request pull to meta-swi/external.mk ?


#8

We assume that you are requirement is to sumbit the patches to gerrit/git to checkin the changes that has done.
For submiting patches which is related to gerrit you can refer the link https://www.tutorialspoint.com/gerrit/gerrit_make_and_commit_your_change.htm


#9

Sorry, no.

I would like to submit patch to meta-swi/external.mk with replacement PWD to CURDIR to allow “make -C yocto” because it is a best practice.


#10

May i know your setup information. i.e, from which path you are executing “make -C yocto” is it customized code base? as we are not observed Makefile in packages directory after downloading legato packages to provide “make -C yocto”.
Usually We have to download yocto source from “source.sierrawireless.com” and then we need to provide make.


#11

It is common professional clean practice to use “make -C prj” instead “pushd prj; make; popd”. I suppose it should be supported.


#12

Please find the attachment for replacement of PWD to CURDIR in Makefile. We need to change in Makefile which is present in yocto directory.We have compiled with “make -C yocto” it has build fine.Makefile (7.3 KB)


#13

Thanks.
Actually I would like to receive credit as open source developer.