Dev Studio says error in program when installing, but doesn't say where

So, I have an app I’ve been debugging, using the “build and start” button. App runs fine. So, I make a few more changes, verify it compiles OK, then hit the “build and install app” button. Builds fine, but when it goes to install it, I get a message saying there is/are errors and do I want to install it anyway. However, the build went fine, I see no errors and there aren’t any other errors that I can see.

How would I find out what the errors are?


Hi @EvetsMostel

Is there any “marker” in the Problems view, concerning this project? (screen capture?)
Despite the built is OK, this kind of warning will occur as soon as there is at least one error marker on the project.

Hi @daav,
Yes, there is one there:

“‘ConnTest179’ library project is referenced, but this project does not have a build configuration compatible with the ‘Target_Legato_Debug’ one. Building the ‘Target_Legato_Debug’ configuration may fail: please create a compatible build configuration in ‘ConnTest179’ project.|ConnTest179||Build Configurations > Manage|Developer Studio Problem|”

However, if I DO go and create a new target, (there isn’t a lot of options than specifying the name), there is no “build target” listed in the project unless I create one. So I created one, but I still get the same error. So, I’m not sure what this has to do with anything… ?

Hi @EvetsMostel

What kind of project is the ConnTest179 one? Any reason to have your main project depending on it?

That’s what’s confusing to me. ConnTest179 is the name of the project and hence the name of the exe. It has two components. It works fine. Not really sure what the issue is.

Hi @EvetsMostel

Maybe you can have a look at the Project Properties > Project References page, and uncheck anything? Or zip and share your project here?

That did it! Thanks, @daav!