WP8548 I2C bus lock up when read ADC2 and ADC3


#1

Hello,

I have this problem several months ago. In my program, the I2C lock up in a few minutes or hours.

I use I2C bus to read two external chips and I need to read the four internal ADCs.

In this document, they talk about this problem on page number 34:

https://source.sierrawireless.com/resources/airprime/software/release_notes/wpx5xx-release-16,-d-,1-customer-release-notes/

It says that the problem was solved in release 13, but I’m using de 16.1 release and I have de same problem.

I have done a basic program in which only read the ADC2 and 3, and read an external i2C chip periodically. I run this program in Mangoh Green and the I2C bus lock up in about 10 minutes.

Anyone had this problem? What can I do? Is Sierra going to fix this error?


#2

Hiya,

Did you get this solved?

I also think you’ve been confused by the release numbers.

Release 13 refers to the modem firmware (and supporting linux distro) for the WP85 device. 16.10.1 refers to the Legato release that is running on top of the R13 release.

I strongly recommend that you go to ‘the source’ and get the latest version of Firmware (R14) for teh WP85, and update to a later Legato release at the same time.

This should solve your problem.

ciao, Dave


#3

Hello,
Are you sure? I think that the last version is the R16.1(18.06.4) :

https://source.sierrawireless.com/resources/airprime/software/wpx5xx/wpx5xx-firmware-latest-release/

Am I wrong?
thank you.


#4

HI @Riegosalz,
an internal analysis is on going on this issue.
As you mentioned an issue with similar effect was already solved in release 13.
here the root cause could be different,
keep you inform on the investigation
best regards,


#5

OK! I wait for news.
Thank you


#6

Hi @plu

Could you give us a status update regarding the I2C issue?

Thank you.


#7

Hi @johnn,
the root cause of the issue is not identified yet; the investigations are on going to replicate and determine the cause;
I keep you inform,
best regards,


#8

Hello,
Is there news about this problem?
I have a very big problem.
What exactly depends internally on the i2C? Is there any document about this?
thank you