Wp7502 unresponsive


#1

Hi There

I have a mango red with a wp7502 module. I think i have misconfigured it since i am now unable to connect to it.
I used the pmtool to set bootOn gpio 38 low
and ran a pmtool shutdown

I tested that i could wake the module by connecting pin1 on cn312 to to pin 6 on cn307
(should pull gpio 38 low)’
And that worked fine the first time i tested it.

Then I removed my usb cables (from both serial and usb port and now i am unable to get in touch with the module, I can see that it must be running since it consumes 138 mv power by there is no response neither on serial or usb. (usb dont enumerate at all)

Anyone who has any ideas on how to get in touch with the module again?
Is there a way to perform a factory reset?

Best regards

Kurt


#2

Please try to put the pin #7 of SW401 on your mangOH Red board to “ON” and connect USB cable to your windows PC. You should see DM port for firmware upgrade.
See if it helps.


#3

Hi JordanZhao

Unfortunately I already have tried this without any luck.

Best Regards

Kurt