Voice call using AT commands


#1

Hi,
I am using mangoh red 7502 module.And I am trying to write Voice Call program using AT commands . Program is running but unable to make a call .I tried using/without using bindings in .adef but unable to solve the problem.I am attaching the screenshot of my program and result as well.Should any changes be made in this program.
image


#2

Hi @Sahithi,

this is quite strange to use AT commands from a Legato app.
Although it’s possible, the Legato Service APIs are there to make things easier and more reliable: https://docs.legato.io/latest/legatoServices.html

In your case you might want to look at https://docs.legato.io/latest/c_le_voicecall.html#c_le_voicecall_outgoing


#3

We are using Legato 16 version .I already tried to use Legato Service APIs but we are unable to include these files-
#include “mdc_interface.h”
#include “le_audio_interface.h”
#include “le_voicecall_interface.h”. We included bindings as well.
That’s why i am trying to use AT commands in the system function.
image


#4

Hiya,

I can confirm that voice calls work (DTMF in, playback .wav files back) on a WP85 using legato 16 … I’ve done it a few times.

But … I suspect that you haven’t got your development environment set up correctly. You don’t need to include the individual header files - all you need to include at the top of any legato file are:

#include "legato.h"
#include "interfaces.h"

interfaces.h is built by the legato build system and contains the appropriate header files for any of the defined bindings.

ciao, Dave


#5

1.I have installed Legato16.10.4 on my host(Windows10).I have installed Legato application Developer studio version-5.3.1.I heve mangoh red board with me it has WP7502 chip on it . i am able to run some programs like serial read/write,sms etc.When i tried to run the voicecall program with below header files, but it is showing error.
#include “mdc_interface.h”
#include “le_audio_interface.h”
#include “le_voicecall_interface.h”.
If the header files are removed the APIs are not working .So please kindly guide me with my problem.
2.I am also unable to run NTP APIs as well.I tried NTP through UDP , it is not showing any error but it is not giving any reply. I used the URL “1.ro.pool.ntp.org” and port no:123.

ntp date -p 1.ro.pool.ntp.org
The above command is also not working .
Please help me with this as well.


#6

On 16.10, I’m not sure that the interfaces.h is available.

One thing though is that you should be including le_mdc_interface.h, and not mdc_interface.h.
I very very highly recommend solving your building issue instead of going the AT command route.

PS: Also it would be best to switch a more recent version of Legato.
Release 16 is available for your module: https://source.sierrawireless.com/resources/airprime/software/wpx5xx/wpx5xx-firmware-release-16/
It has Legato 18.06.1 .