Command 'X' not found

#1

Hi I recently Leaf and the new Leaf extension for VSCode. I reached step 6 and I can’t get the extension to ask about the Legato definition file. When I run the command <Legato/System: New app> or <Legato/System: Create system> I get an error in the lower right "command 'cmd.legator.system.create. not found.

Thanks.

#2

Hi,

If you go onto the leaf extension and look at your profiles do you have the swi-vscode-support_190424 package installed into your profile?

We are still in an alpha state and haven’t fully integrated the tools yet by default into the package (this is coming). It looks like you don’t have mkedit installed (one of the tools that vsCode relies on to create the system).

Your installed packages should look something like this (I’m on an internal version atm so the package name will be different then what you have for the main leaf package but you want to make sure that swi-vsode-support is added to your current profile):
image

And then try to reload the window.

I hope that helps, if not please provide a screenshot of your leaf profiles and I can see what the issue is.

#3

@Sarra here is the screenshot for the Leaf profiles you asked for.

#4

The issue is that you don’t have the vscode support package installed into your profile. You need one for each profile you are going to use. We have a number of extra tools that the IDE uses that aren’t part of the Legato Application Framework (yet, they will be there in the future).

What you need to do is add a filter above for “vscode” and have both master and vscode filter selected (unselect any others). You should see 2 packages, the one labeled 190424 is the newest and should be used.

Click on the swi-vscode-support-190424 package and click on Add to profile…
That should add the tools that you need to your profile and get ride of the error that you are seeing.

#5

@Sarra Thanks, I will give it a try and let you know.

#6

@Sarra This worked thanks!