System Update not Trying New Versions


on one of our modules we have a strange behavior. After updating via update *.wp76xx.update the new system isn’t tried:

root@swi-mdm9x28-wp:~# legato status
Systems installed:
  2 [untried]
  1 [good] <-- current
Legato framework is running.

What prevents the new system to be tried?


You need to check the logread when you update this file.

BTW, I don’t see such issue in mangoh layer, you can diff the .sdef file with yours

We are using the default.sdef from legato which is installed via leaf:

#include $LEGATO_ROOT/default.sdef


So I tried it again, but the system doesn’t change. Please see the attached log: update-log (380.4 KB)

When I check the errors I can see this line:

Aug 18 10:24:25 swi-mdm9x28-wp user.err Legato: =ERR= | startSystem[1090]/framework T=main | start.c GetStatus() 1208 | Failed to read status of system '2' (No such file or directory).

But the folder is there:

root@swi-mdm9x28-wp:~# legato status
Systems installed:
  2 [untried]
  1 [good] <-- current
root@swi-mdm9x28-wp:~# ls /legato/systems/
2/        current/

It would be really bad if this happens in production. As I said, this only happens on one of our boards. The other ones are working fine.

The one that makes the problems has this legato version:

root@swi-mdm9x28-wp:~# legato version

does problem still happen if you re-flash the legato image on this module?

I haven’t tried that yet. I’d like to know what’s going wrong here to eliminate or react to the problem when doing software updates in production

cannot find related message to explain this…

BTW, for production, I would suggest you building the application together to the legato image.
You can see here:

Ok, I’ll keep that in mind for production. Thanks for the information!