Fundamentals - WP7607 Can't develop and test applications

Hello everybody,

I just started working on my first mangOH Green project, however, I have some problems getting past step 4 of the mangOH Green Fundamentals: (http://mangoh.io/uploaded-documents/Reference/mangOH%20Green/Discover/Getting%20Started/GreenWindowsCLI/#t=Tutorials_-_HTML5%2F4118961_Tut_DevelopApps%2F4118961_Tut_DevelopApps.htm)

When I type in: $ cd $LEGATO_ROOT/apps/sample/helloWorld I get the error: bash: cd: /apps/sample/helloworld: No such file or directory.

I already tried to follow the Youtube Tutorial (https://youtu.be/rUqzkDaQNa4?t=81) on how to setup up Legato but I can’t get passed the point where they install a .sh file. Simply because I don’t know where to find that file. Do you know where I can get the .sh file from? Is there a proper way to install Legato on a VM?

As an alternative, I tried to create a helloworld project with Developer Studio but I can only select the following modules: AR755x and AR865x. Seems like Developer Studio doesn’t support the WP7607 as of now. Do I have to install anything prior to creating a new project?

Best,
Thomas

you need to select the correct module

I’m afraid I can’t choose between more than the aforementioned options at the moment.

I just tried to setup up the development environment but I keep getting the same error after trying to set up “wp76stable_1 - p swi-fx30-cat1_1.0.0” . Even after typing in “leaf profile sync” it’s still not working.

do you mean you cannot choose WP76 in developer studio?

Exactly.
Do you also happen to know why I can’t sync the desired profile?

which ubuntu version are you using?

My current version is Ubuntu 18.04.4 LTS.

No problem is found on my Ubuntu18.04 on command “leaf setup wp76stable_1 -p swi-fx30-cat1_1.0.0”.

Okay that’s weird.
For some reason the repo is not signed when I try it.
By the way, the same happens when I run the command “sudo apt-get update”.

suggest you start with a clean installation of Ubuntu on VMWARE.