Issue creating CWE and SPK files in WP7702 release 15 firmware

We’ve been having a lot of issues getting the release 15 software to build for the WP7702, however with the download provided earlier and using a VM rather than WPF. We’re now at the final step to create the cwe & spk files for production.

However we’ve run into issues with that as well. With our own project when we load it using fwupdate it fails silently, when using FDT2 we get the following error with the CWE or SPK:

I’ve then made a test project from scratch which should only toggle a led on our board, this does not give an error when loading the CWE or SPK.

However when this is loaded all applications look to have disappeared:

This is the test project, we use the script to build the CWE and SPK files (5.1 KB)

What is going wrong here? How can it generate with incorrect image sizes? why do all the applications vanish when loading the test project?

have you tried to download legato.cwe built by “make wp77xx”?
If it can be downloaded, then you can see here to modify wifi.sdef in order to embed your application to the leagto.cwe:

You can also see here:

the CWE I’m using is the one copied from legato-squashfs.ubi.cwe which is the one legato.cwe links to. I’ve tried uploading legato.cwe using fwupdate and the result is the same:

Using your second link mentions using the -s option for the CWE generation and that looks like it might have fixed it for our application. We will be doing some more testing, but this looks promising.