Cwe install fails


Have built a system with lighttpd and mqtt apps for the WP76. If I install the .update bundle as an overlay everything works fine.
But If I use systoimg and build a .cwe that I install with fwupdate the module reboots and legato is no longer running and can’t be started.

If I exclude the lighttpd module it works. My .cwe file is about 9MB with the lighttpd components and 8.9MB without. Is this a size issue or what is it?

Can’t find any error messages that indicate what’s the problem.

you can check the legato framework size by " more /proc/mtd" command.

You can also modify the wifi.sdef to include the application into legato.cwe.

Not sure how to use the “more /proc/mtd” and what mtd im looking for?

But I guess the legato size is the issue?

ubi4_0 is only 8.7MB

Tried to exclude the wifi apps with “export LE_CONFIG_ENABLE_WIFI=n” as my hardware don’t have wifi but the wifi apps are still included.

Didn’t lefwkro is the legato partition?

You need to modify wifi.sdef to remove wifi app

Ok. lefwkro is 08C000 and that is 9 175 040 bytes. Explains why my system with lighttpd is just a bit too big to install.

Will try to remove unused apps like wifi_samples and check what else I can remove.

Are you using Airvantage Services?

Yes I’m using Airvantage for updates, heartbeat and status report.

Did mask defaultAtCommands.sinc and now it works. (My .cwe is 8,651,552 bytes) Not sure if this is something I need. AT commands still work. Did also mask out wifi.adef from wifi.sinc.