How to use ttyAT on mangOH yellow?


I have some question when I used mangOH+wp7607 (system information as below)

I tried to use /dev/ttyAT with microcom , but have some error messages when I send “microcom -E /dev/ttyAT” as below:

invalid number ‘/dev/ttyAT’

How to use ttyAT on mangOH yellow? and cloud I used ppp to dial without any API (e.g. cm data connect)?


how about “microcom /dev/ttyAT”?

do you have a USB connected to the USB AT port of WP module for PPP dial up?

I have found identical problem with some versions of Firmware for FX30 (I’m on my 3rd version try). I believe the problem is a bug in some versions of microcom and the work around for your version is to simply leave out the -E, for example microcom /dev/ttyAT . so now you get no echo but your AT commands will be processed and you will get the response. As a point of reference my original version on the delivered card had the buggy microcom and a nonworking “cm data connect”. Then I upgraded to the latest firmware online, where lo and behold microcom worked but cm data connect still did not. Then I got a firmware version from Sierra where “cm data connect” worked but my buggy microcom was back. However, I need a working connection more than I need Echo with microcom. So I will make do for now. Hope this helps.

Hi carterwe & jyijyi

Thanks for your support, it is helpful to me, the problem has been solved.