How to use FX30 as a router

We connect Windows10 PC and fx30 via Ethernet cable and want to use fx30 as a router.
We were able to ping from fx30 to referring to the ticket below.

”smsC hat.txt” was not created after app runProc modemDemo1 send --exe = send – 1234567“ Sim”

We connect Windows10 PC and fx30 via Ethernet cable however Windows PC does not recognize fx30 properly.

Intel(R) Ethernet Connection I219-LM

  • IP address:
  • Sub-net mask:

We collected wireshark log.
fx30_2.pcap (60 KB)
Do you know root cause from the log?

We tried ping -I eth0 from FX30 and ping from Win PC.

Thank you.

on packet 102-107, we can see the the FX30 sends out ping packet, but we don’t see any reply from Windows PC (

probably this is a Windows PC problem. (e.g. firewall?)

you might also try with linux PC machine and see if it can ping each other.

Hi @12214,

Please install the WP module Windows 10 driver located on the Sierra Source.


Hi Jyijyi,

We try with Linux PC machine, but
But ping is disconnected during ping

legato@ubuntu:~$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=4.37 ms
64 bytes from icmp_seq=2 ttl=64 time=1.57 ms
64 bytes from icmp_seq=3 ttl=64 time=1.70 ms
64 bytes from icmp_seq=4 ttl=64 time=2.10 ms
64 bytes from icmp_seq=5 ttl=64 time=2.55 ms
64 bytes from icmp_seq=6 ttl=64 time=2.60 ms
64 bytes from icmp_seq=7 ttl=64 time=1.57 ms
64 bytes from icmp_seq=8 ttl=64 time=4.04 ms
64 bytes from icmp_seq=9 ttl=64 time=3.28 ms
64 bytes from icmp_seq=10 ttl=64 time=4.03 ms
64 bytes from icmp_seq=11 ttl=64 time=4.08 ms
64 bytes from icmp_seq=12 ttl=64 time=2.87 ms
64 bytes from icmp_seq=13 ttl=64 time=3.15 ms
64 bytes from icmp_seq=14 ttl=64 time=4.14 ms //after this ping, keep disconnecting
— ping statistics —
36 packets transmitted, 14 received, 61% packet loss, time 35511ms
rtt min/avg/max/mdev = 1.576/3.008/4.373/0.984 ms

Do you have any advice?

Thank you.

didn’t you are trying to ping with ethernet?
Is that now you switched to USB ECM interface?

if so, seems to be same issue as this one:

Hi cchenry,

We already installed WIn 10 driver.
We can confirm AT port and DM port in Device manager.
And we can send AT command.

Thank you

Hi Jyijyi,

We were able to access
And we confirmed that we can ping Linux PC and FX30 or not.

1 ssh192.168.2.2
2 app runProc modemDemo send --exe=send – 1234567 “Online”
3 ping from fx30
4 Connect Linux PC and Fx30 using ethernet cable.
5 ping from fx30 (Linux PC interface eth0:
6 ping from Linux PC
7 Open internet browser

#5 and #6 are success.
please see the attached “ping.png”.

In#7, we can not open internet browser.

Do you have any advice?

BTW, in our ethernet setting, please see the attached “Ethernet_connected.png” and “Ethernet_setting.png”.

Thank you.

you might have a look on this script which is working fine for mangoh red board to share radio data to ethernet client.

Indeed, the FX30 will not route traffic by default across interfaces. Some development is necessary to achieve this.


Hi Jyijyi,

Thank you for providing the advice.
Please tell us about

We tried below prcedure.

  1. Download the script to the MangOH device (also found under /scripts in theMangOH GitHub) using the following:
    scp ./scripts/ root@

We confirm that is saved to /tmp/ of FX30 after above procedure.
However once power off FX30, is erased from /tmp/ of FX30.

Is this correct behavior?
In other words, do we have to download every time that we power off FX30?

Thank you

You can put the file in /home/root