R15 Legato_21 and Talon Wifi IOT card

I have a Talon Wifi card in a FX30s running Legato 21. Does the fx30_catm_4_1_0 release come included with support for this card. I cannot see any of the ti drivers. If I need to compile , are there any instructions ?

other user can make it work, you can check with him here:

So my FX30 is missing hostap* too

I also tried with fx30_catm_4_1_0 images like you did in that thread (you tried an older version). But even after installing


I cannot find hostap

Is the solution to rebuild yocto ?

And we do not need to modify anything (gpioexp inside tiwifi ) correct? Because it appears the whole problem is with hostapd missing. Also we really dont need hostapd because we are going to run this in client mode but perhaps wifiService is failing because it cannot find hostapd

I think you can try that to include hostapd first.

ok, since /bin is read-only is there a simple way to only copy hostapd and make it appear in /bin or should I have to re-generate the .SPK and download again ?

I have hostapd from my previous yocto build but it did not get included due to “REMOVE” in the bitbake recipe.

Here is an example to overlay on read only file system.

Of course you can also rebuild the yocto image

thanks. So I did these 2 things (this may help others)

  1. Overlay /bin and copied hostapd to /bin on the FX30
  2. Enabled wifi client
  3. modified tiwifi and removed all the gpioexp stuff from there (it was giving me i2c errors)
  4. used wifi client to setup the connection

This seemed to work one time BUT after I reboot the kernel throws a panic when wifiService invokes it via pa_wifi.sh

This is a problem because we really need this card to be supported on R15

dmesg shows it occurs when

/etc/rcS.d/S99start_qti_le script is run

I can confirm this issue is linked with wifiService.

To reproduce

  1. Remove gpioenable stuff from tiwifi and allow the script to run fully
  2. Reboot system or simply restart wifiService

Kernel will throw panic

[ 188.264965] wlcore: wl18xx HW: 183x or 180x, PG 2.2 (ROM 0x11)
[ 188.321788] wlcore: loaded
[ 189.580843] wlcore: PHY firmware version: Rev
[ 189.638200] wlcore: firmware booted (Rev
[ 189.661852] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 191.013706] wlcore: down
[ 191.080642] [RMNET:HI] rmnet_config_notify_cb(): Kernel is trying to unregister wlan0
[ 191.140458] [RMNET:HI] rmnet_config_notify_cb(): Kernel is trying to unregister wlan0
[ 192.160543] mmc0: clk: 0 clk-gated: 0 claimer: kworker/0:1 pwr: 0 host->irq = 131072
[ 192.160565] mmc0: rpmstatuspltfm(0:1:0)
[ 192.160577] ------------[ cut here ]------------
[ 192.160618] WARNING: CPU: 0 PID: 14 at drivers/mmc/host/sdhci.c:1851 sdhci_request+0x18c/0x2d8
[ 192.160627] sdhci in bad state
[ 192.160637] Modules linked in: arc4 machine_dlkm(O) wm8944_dlkm(O) wcd9330_dlkm(O) wcd_cpe_dlkm(O) wcd_core_dlkm(O) stub_dlkm(O) platform_dlkm(O) q6_dlkm(O) adsp_loader_dlkm(O) apr_dlkm(O) snd_hwdep snd_soc_core snd_compress snd_pcm snd_timer snd soundcore [last unloaded: cfg80211]
[ 192.160758] CPU: 0 PID: 14 Comm: kworker/0:1 Tainted: G O 4.14.253 #1
[ 192.160770] Hardware name: Qualcomm Technologies, Inc. MDM 9607 (Flattened Device Tree)
[ 192.160794] Workqueue: events_freezable mmc_rescan
[ 192.160846] [] (unwind_backtrace) from [] (show_stack+0x10/0x14)
[ 192.160876] [] (show_stack) from [] (__warn+0xd4/0xf0)
[ 192.160906] [] (__warn) from [] (warn_slowpath_fmt+0x34/0x44)
[ 192.160939] [] (warn_slowpath_fmt) from [] (sdhci_request+0x18c/0x2d8)
[ 192.160978] [] (sdhci_request) from [] (mmc_start_request+0x334/0x36c)
[ 192.161010] [] (mmc_start_request) from [] (mmc_wait_for_req+0x88/0xec)
[ 192.161036] [] (mmc_wait_for_req) from [] (mmc_wait_for_cmd+0x64/0x74)
[ 192.161066] [] (mmc_wait_for_cmd) from [] (_mmc_select_card+0x58/0x60)
[ 192.161097] [] (_mmc_select_card) from [] (_mmc_detect_card_removed+0x2c/0xf4)
[ 192.161129] [] (_mmc_detect_card_removed) from [] (mmc_sdio_detect+0xa8/0xdc)
[ 192.161160] [] (mmc_sdio_detect) from [] (mmc_rescan+0x184/0x55c)
[ 192.161189] [] (mmc_rescan) from [] (process_one_work+0x25c/0x43c)
[ 192.161219] [] (process_one_work) from [] (worker_thread+0x304/0x46c)
[ 192.161251] [] (worker_thread) from [] (kthread+0x12c/0x144)
[ 192.161285] [] (kthread) from [] (ret_from_fork+0x14/0x2c)
[ 192.161300] —[ end trace f0f9659dee6639f7 ]—

@sunil.somarajan Does this relate to the hostapd in R14?

@ccu , do you see such issue?

I am using R15 (hostapd from R15 yocto build). this is related to WifiService. So I really dont need wifiService or the wifi client tool.

How can I autostart wlan0 using wpa_supplicant.conf and obtain an IP address ?

from the dmesg, the crash is in SDHC pin…

You said that you make it work once, can you revert back and redo ?

nope, we haven`t seen this issue