Flash size wp7607


as mentioned in the data sheet the wp7607 flash size is 256MB

however, the root FS size as defined by Yocto is ~40MB, how can I expend the FS size?

how much space is actually available on the wp7607?

additionally, I noticed that modifying the partitions is not supported by the wp7607 (a post from 12.17)

is there any update on that issue?

I don’t see there is way to resize the partitions now…
But in case you want to include more file in FS, you can try modifying ./meta-swi/meta-swi-mdm9x28/conf/machine/swi-mdm9x28.conf ? (parameter UBI_ROOTFS_SIZE)

I did that and I succeed in creating a larger FS

but, without the option to modify partition sizes, when I flash that image the device stops functioning properly (legato components do not function well)

this is well understood since I “overrun” existing functionality

please advice how it’s possible to use a larger FS

thank you

The UBIFS size is something a bit from the past, as we are currently not using the generated ubifs rootfs (which has a static size) and use a squashfs rootfs instead (dynamic size, compressed and read-only).

The flash layout is fixed on wp76, so it is not possible to resize the rootfs partition once the max is reached. The system can be extended through Legato applications, and/or by putting content in bigger partitions such as /mnt/flash.
Overall we recommend the rootfs to remain small for security reason.

1 Like

I understand.

but in my case, for example I would like to include ffmpeg to the Yocto build, now image created is bigger then UBI_ROOTFS_SIZE so image is not getting built.

however if I resize parameter UBI_ROOTFS_SIZE, image can be built.

how else can I accomplish including more packages to the Yocto build ?

not sure if you can remove some packages so that you can run your yocto.
e.g. ./meta-swi/meta-swi-mdm9x28/recipes-core/images/mdm9x28-image.inc

And since you’re unlikely to use the ubifs image, you can disable it’s generation by commenting out the 2 lines in meta-swi/meta-swi-mdm9x28/conf/machine/swi-mdm9x28.conf:

# Add ubifs file system
IMAGE_FSTYPES += "2k.ubifs"
IMAGE_FSTYPES += "4k.ubifs"

So after it should look like:

# Add ubifs file system
#IMAGE_FSTYPES += "2k.ubifs"
#IMAGE_FSTYPES += "4k.ubifs"

You might also need to edit meta-swi/meta-swi-mdm9x28/recipes-core/images/mdm9x28-image.inc to change

for rootfs_type in ubifs squashfs; do


for rootfs_type in ubifs; do

while it does solves the error in build issue, when I flash 'yocto_wp76xx.4k.cwe" the wp76xx still starting to experience “strage” behaviour, that is because of course the on-board partitioning does not support the image size

please advice

Have you tried to remove some packages?

I can not be limited with the rootFS size to 38MB only

I want to make sure, after performing the steps you described:

modify: meta-swi/meta-swi-mdm9x28/conf/machine/swi-mdm9x28.conf

modify: meta-swi/meta-swi-mdm9x28/recipes-core/images/mdm9x28-image.inc

do I still download the image: yocto_wp76xx.4k.cwe ?

if I would like to go in the path of removing existing Yocto packages (still a risk, since it means I always need to fear to reach the maximum limit)

can you recommend of large packages I can remove (for example I do not need python support)

since ffmpeg is quite large

thank you

Of course you should download yocto_wp76xx.4k.cwe

Is there any update on the issue above? I ran into same issue with WP7609. I have to include some python packages and other modules, and if I increase UBI_ROOTFS_SIZE then system starts behaving strange.
I would appreciate your help.

not sure if this helps you:

Thank you @jyijyi for sharing this document.
But I am trying to get image (xxx.cwe) file ready for production and it requires all modules with my application included during the build time.
I have a build setup and able to build image successfully using make image_bin.
I would really appreciate if you could help me with resolving this issue.

@jyijyi Or is there a way to add files to User Data or User App partition during build time?

How about download the legato app which brings those binary files to module?

I have setup visual studio code with leaf and installed complete SDKs for WP7609.

How can I add my files to the legato app and can I incorporate these with yocto build?

you can see here on how to bundle file into legato application.

@jyijyi Thanks for responding.
So there is no way for me to add large packages with the yocto build. eg. ffmpeg, qt5 in this module?