[Fixed] Time not updating when connected to cell network

Hi

I have a mangoh red board which I have connected to the cell network and have an active data connection to the internet through the cell network. Alas, however, even though https://docs.legato.io/latest/c_rtc.html tells me that the timeservice should update the target time automatically, the target time is still set to sometime in the 1980’s.

Do I have to do something for syncing the time between the cellular network time and my target?

Please check in AT command port that if the modem has update the network time after registered to the network. (+CTZU is for Automatic Time Zone Update)

at+cclk?
+cclk: “18/06/08,01:35:13+32”

OK
at+ctzu?
+CTZU: 1

OK

I solved this by changing the time service.
Setting the proper date/time was done by navigating to /etc/time_service.conf and editing the time service to be ntpd_time instead of qcom_time.

I would rather not use NTP as I cannot be sure that the product will have a data connection. I am however relatively certain that I can get a connection to the cell net for time update even though I cannot get a data connection. But will try the AT commands asap

I have just found that my custom yocto image are not exposing the /dev/ttyAT. Anyone knows what can be the cause of that? Is there a driver that I need to install into the kernel?

I have just found the issue. In our yocto setup we had overwritten the bbappend for mdm9x15-image-minimal and have by doing that removed all the .inc files included into this. Therefore there were some scripts and other stuff that we didn’t get. Some of these were important for making a symbolic link from /dev/smd08 to /dev/ttyAT and to make sure that the time is syncing correctly.

Therefore, including all these .inc files again did the trick. Thank you all for helping me.