WP76xx Date and Time not updated


#1

Hello,

I’m developing an application using WP7607-1 module and have a few doubts with the Date and Time.

According to what I’ve read about the time update, the Time Daemon should update the time automatically when a network is successfully reached (Doc).

However, I’ve never seen the time being updated automatically. If I don’t manually update it, it would stay in 1980.

I understand WP76xx doesn’t include an RTC which prevents the time to be kept while not powered but I don’t understand why the time isn’t updated upon network connection.

The legato package I’m developing with is the following: Legato for WP76 R10.1 (18.6.3.wp76xx-docker-201810311826) for Windows

If it’s normal time doesn’t get updated I will add a time update handler in charge of manually retrieving and updating but I feel like I’m missing something and I might rewrite code that is already handled by the framework.

Thanks for your help,
Best regards,


#2

Not sure if “ntpd -q -p pool.ntp.org” can help you to update the clock after data establishment.

In my side, the module clock will be automatically updated:

root@swi-mdm9x28:~# cm data connect &
root@swi-mdm9x28:~#
root@swi-mdm9x28:~# Setting up profile 1
Setting access point name ... ok
Setting packet data protocol ... ok
Setting Authentication ... ok
Connecting ... ok
Checking if device is up ... ok
Routing ... ok
Updating /etc/resolv.conf ... ok
Updating /etc/resolv.conf ... ok
Testing connection ... ok

[1]+  Done                       cm data connect
root@swi-mdm9x28:~#
root@swi-mdm9x28:~# ping www.google.com
PING www.google.com (216.58.199.100): 56 data bytes
64 bytes from 216.58.199.100: seq=0 ttl=55 time=16.090 ms
^C
--- www.google.com ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 16.090/16.090/16.090 ms
root@swi-mdm9x28:~# date
Thu Jan 31 09:28:09 HKT 2019
root@swi-mdm9x28:~# cm info
Device:                WP7608
IMEI:                  352913090100734
IMEISV:                4
FSN:                   XG805285330204
Firmware Version:      SWI9X07Y_02.16.02.00 000000 jenkins 2018/04/19 19:59:02
Bootloader Version:    SWI9X07Y_02.16.02.00 000000 jenkins 2018/[  140.178179] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x0c1300c8 OPER:0x00000090
04/19 19:59:02
MCU Version:           002.009
PRI Part Number (PN):  9907762
PRI Revision:          001.001
Carrier PRI Name:      GENERIC
Carrier PRI Revision:  002.032_000
SKU:                   1103788
Last Reset Cause:      Power Down
Resets Count:          Expected: 207    Unexpected: 9

#3

Hi jyijyi,

Thanks for your answer.

I’ve synchronised my module with airvantage platform and now it seems to update the time at each heartbeat.

Thanks for your help,
Regards,
Ben