Qcom timezone sync not working

Hi,
Im using qcom time as default in WP7502. I can sync system time with “date”:
Testing connection … ok
root@swi-mdm9x15:~# date
Sat Nov 9 08:37:06 UTC 2019

But how can i update timezone in my code? I tried at-commands:
+CREG: 0,1
OK
at+cclk?
+cclk: “19/11/09,08:33:33+08”
OK
at+ctzu?
+CTZU: 1
OK
But no success, timezone is still wrong. How to change timezone from my code?
Thanks for any help.

So my question is how can I change Legato system time zone by my code. If the modem goes to another country, time zone should be updeated automatically. Like my mobile phone does when I travel to different countries. Any instructions please?

Did +cclk value change correctly when you move to another country?

yes, +cclk shows correct time and timezone. How to update Legatos timezone?

Do you mean the "date"command not working?

“date” command is working for time and date, but timezone does not change.

Can this help?
https://www.thegeekstuff.com/2010/09/change-timezone-in-linux/

Also you can have a look here

Yes, we checked this earlier, but we could not find “localtime” or “timezone” files in etc. Where are their located in Legato?

How about setting timezone by date command
How about using command “tzoneset”?

How about the following?
https://docs.legato.io/latest/toolsHost_settz.html

Yes, settz works with host. But we need to do it by our code.
Is there “timezone”-file available in legato?

I dont know as i don’t have module in hand, you can search by yourself.
Btw, How about using command “tzoneset”?

We can set the timezone by host machine, but as I understand it is not possible to do it by code. Anyway we will manage with this, Thanks.