Disable breakpoint

Hello
I used VS code whith leaf plagin 1.0.1
wp7502. legato 19.11.1
OS ubunt 18

i set breakpoint in funtiion COMPONENT_INIT().
When a debugging session starts, breakpoints cannot be registered.

But if i set breakpint in main() function then everything works.

how to fix it?

my launch.json

{
// Use IntelliSense to learn about possible attributes.
// Hover to view descriptions of existing attributes.
// For more information, visit: https://go.microsoft.com/fwlink/?linkid=830387
“version”: “0.2.0”,
“configurations”: [
{
“name”: “Debug Legato application (launch)”,
“type”: “legato-launch”,
“request”: “launch”,
“application”: “myApp”,
“executable”: “myAppComponentExe”
},

    {
        "name": "Debug Legato application (attach)",
        "type": "legato-attach",
        "request": "attach",
        "application": "myApp",
        "executable": "myAppComponentExe"
    }
]

}

when i in debuggin session.
i try set breakpoint and get log " Send Event AD7BreakpointErrorEvent**"

my log debugg session.

: (472233) ->1097^done,bkpt={number=“5”,type=“breakpoint”,disp=“keep”,enabled=“y”,addr="",pending=“main.c:7”,times=“0”,original-location=“main.c:7”}
1: (472233) ->(gdb)
1: (472233) 1097: elapsed time 1
1: (472233) Send Event AD7BreakpointErrorEvent
<-- C (disconnect-59): {“command”:“disconnect”,"arguments{“restart”:false},“type”:“request”,“seq”:59}
1: (1338143) <-1098kill
1: (1338144) ->&"kill\n"

what’s wrong?
how fix it?
any ideas

@zuuuuk, Do you still have this issue? I just did a quick try with COMPONENT_INIT() and the Breakpoint it’s maintained