Can't set WP7504 to LTE mode on mangOH


#1

Below are the commands and responses when I try to change the rat mode. The SIM is LTE compatible. Any idea why I’m not able to switch modes? My cell phone is reporting a LTE AT&T connection ( different SIM ), although weak. I’m building the yocot/legato source from Legato-Dist-Source-mdm9x15-SWI9X15Y_07.11.21.00.tar.bz2. Every attempt to change the mode results in “Failed to set rat value”. I’m able to connect to UMTS fine.

root@swi-mdm9x15:~# cm info
Device: WP7504
IMEI: 356207070037255
FSN: P1636500121210
Firmware: SWI9X15Y_07.10.04.00 r32393 CARMD-EV-FRMWR1 2016/06/01 20:30:40
Bootloader: SWI9X15Y_07.10.04.00 r32393 CARMD-EV-FRMWR1 2016/06/01 20:30:40

root@swi-mdm9x15:~# cm radio
Current Network Operator: AT&T
RAT: UMTS network (LE_MRC_RAT_UMTS)
Status: Registered, home network (LE_MRC_REG_HOME)
Signal: Good signal strength (3)

root@swi-mdm9x15:~# cm radio rat LTE
Failed to set rat value

*Update: Here is the syslog output from when I attempt to switch the radio RAT mode to LTE

Jan 3 18:37:07 swi-mdm9x15 user.err Legato: =ERR= | modemDaemon[517]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 768 | Sending QMI_NAS_SET_SYSTEM_SELECTION_PREFERENCE_REQ_MSG_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=3.[0x03]
Jan 3 18:37:07 swi-mdm9x15 user.err Legato: =ERR= | modemDaemon[517]/modemDaemon T=main | le_mrc.c le_mrc_SetRatPreferences() 1337 | Unable to set the Radio Access Technology preferences.
Jan 3 18:37:07 swi-mdm9x15 user.err Legato: =ERR= | cm[1251]/cm T=main | cm_mrc.c cm_mrc_ProcessRadioCommand() 416 | Failed to set rat value


#2

Did you check if the AT&T bands are supported on WP7504?
WP7504 supports LTE B2, B4, B5, B12, B17, B25 and B26.


#3

It looks like AT&T uses bands B2, B4, B17 & B30 for LTE.