Can't mksys a simple project


#1

Hi, I am trying to create a cwe, first by creating an sdef and building using mksys.

My app builds fine using mkapp, I then include it in the sdef and build using mksys and get the following binding error

"Binding to non-existent server app ‘avcService’

I am building with R14 or 16.10.1.m3 for wp85 (FX30).

It is possible my sdef file is to simple with

apps:
{
	AVConnect.adef
}

interfaceSearch:
{
    $LEGATO_ROOT/interfaces/airVantage
}

I added the interfaceSearch bit, to hopefully help it resolve the binding, but that did not work.

What am I missing?

Thanks,

Karl


#2

Did you include the legato default.sdef?


#3

No I did not, here should I include that? In the sdef I created or the command line?


#4

I think you should include in sdef file


#5

Thanks for the info @jyijyi R14 (16.10.1.m3) does not seem to recognise “#include” in the sdef file. I get the error

Unexpected charachter: ‘#’

Any thoughts?

My sdef now looks like

#include "$LEGATO_ROOT/default.sdef"

apps:
{
	AVConnect.adef
}

interfaceSearch:
{
    $LEGATO_ROOT/interfaces/airVantage   // Dir containing Legato AirVantage services APIs.
}

#6

I copied the content of default.sdef into my sdef which has worked.

Thanks,


#7

I just tried the following and no problem is found:
owner@CNHKG-EX-001367:~/legato/packages/legato.framework.16.10.3.wp85-wp750x-201705031608/resources/legato$ make wp85

So I think you can modify /legato/packages/legato.framework.16.10.3.wp85-wp750x-201705031608/resources/legato/system.sdef and put your application into it to build.


#8

@jyijyi thanks for the reply. As mentioned moments before your post I managed to do a straight mksys, copying in the default.sdef file contect.

However when I add -t wp85 to it, I now get

2>  _build_DLC_FX30/wp85/component/58ff4d965687e8773f5f4b1df116b11b/obj/libComponent_uartMode.so: undefined reference to `pa_uartMode_Set'
2>  _build_DLC_FX30/wp85/component/58ff4d965687e8773f5f4b1df116b11b/obj/libComponent_uartMode.so: undefined reference to `pa_uartMode_Get'

and it stops at this point… so there might be more I guess…


#9

how about putting your application in /legato/packages/legato.framework.16.10.3.wp85-wp750x-201705031608/resources/legato/system.sdef?

After that you can make the legato cwe image.


#10

Hi @jyijyi, I have managed to make wp85 with the changed system.sdef as suggested. This seems to create a rather small cwe file in the build/wp85 folder. It is only 2.5Mb as opposed to the 55MB 'mcu-rmfw-boot-yocto-legato_wp85.cwe' file I have been using. How to there two files compare?

Are there extra steps for creating the full cwe image I download to the modem?

Thanks,


#11

that big file included all the image, mcu, bootloader, yocto linux, legato.
if you just update the legato app, there is no need to update all of them.


#12

@jyijyi thanks for the quick replies!

That should be fine. Can I include an updated startlegato.sh file in my apps cwe file? Or does that need to be part of the larger cwe?

I am basically trying to create a roll back image for for device. Too make sure it always has my app and config on it, so that I can contact it if it resets itself.


#13

you can write a unsandboxed application to modify the startlegato.sh.


#14

Good idea. Thanks I will go with that for now.