Building for Legato 21.05.0 fails on iperf3

I’m having issues building an application for Legato 21.05.0 on a FX30 CAT-M (, using the swi-fx30-catm_4.2.0 package.
It tries including from /usr/include when building the 3rdParty iperf which comes with the package (fx30-catm-legato_21.05.0).

Makefile:961: recipe for target 'iperf3-main.o' failed

My guess would be that the include directory is chosen wrong?

what application are you trying to build?
legato application?
or just compiling a linux application with FX30 toolchain?

Yeah I’d like to build a Legato application and it builds fine with swi-fx30-cat1_2.0.1 and others but not with the described package.

they are using different legato version…

can you attach your application here?

Can’t attach the application here, it’s not meant for public purposes.
I’m using different versions of the FX30 hardware, therefor the example.
I’ve got a FX30 WP77 for asia pacific and a FX30 WP77 for EMEA… and they have different Legato versions but should run more or less the same application.

If necessary I could write a simple example application to publish it here… but I really feel like the error is originating from the legato package.

so you don’t see problem on swi-fx30-catm_3.0.0 but error start since swi-fx30-catm_4.0.0, right?

Yes, a simple application would be good to reproduce issue

It is really strange… today I tried compiling it in a new leaf workspace and all of a sudden it just works.
I tried creating a simple example where it doesn’t compile… well it sort of solved itself, thank you for your time, I’m sorry I didn’t try this earlier but I also can’t explain it to myself right now.
The build* directories were always removed before running a new build and I didn’t see any other temporary files that could interfere with the build process.

Ok, I think I figured it out… it was the leaf-workspace.json which contained the environment variable LEGATO_DEV_MODE_ENABLE.
And that caused the build to fail somehow.