WP85 firmware packages - Release 11 - Freezing user space


#1

Hello forum,

I just tried the latest version of WP85 firmware packages available from: http://source.sierrawireless.com/resources/legato/wpfirmwarerelease/

I installed it on a mangOH green kit rev7.

I very regulary unwanted reboot and “Freezing user space processes” error.

Thanks,


#2

I think the module goes into “low power mode”. I do not know how to leave this mode. GPIO ?


#3

I understand what happens. The module is enter in “low power mode”.
Actually, I use the mangOH with DC power mode and work with the ethernet interface eth0. In this cas, the mode enter in low power mode…
For wake-up the mode, I must connect the USB and this is not the desired operating mode.


#4

I stopped the legato powerMgr application. Problem solved.


#5

Hi, Actually this is due to USB selective suspend which is taking device to the Auto Sleep mode.
There is no need to stop legato PowerMgr.

The following are the steps to be followed to disable the autosleep mode in WP8548 :

first way (not persistent after a reboot) :
To enable deep sleep, execute following shell command in console:
echo mem > /sys/power/autosleep
In
current firmware by default the deep sleep mode is enabled, and keep in
mind above command shall be executed upon every power cycling in order
for deep sleep mode to be disabled.
To disable deep sleep, execute following shell command in console:
echo 0 > /sys/power/autosleep