Stuck in Low Power Mode - Image Preference Mismatch


#1

Hi everyone,

I’m having some trouble with my WP8548 device. No matter what I do, I cannot get it to come out of Low Power Mode, which it enters immediately upon booting.

I believe it has something to do with how I installed Legato, as running the AT!PCINFO? command gives me the following output:

State: LowPowerMode
LPM force flags - W_DISABLE:0, User:0, Temp:0, Volt:0, BIOS:0, GOBIIM:1
W_DISABLE: 0
Poweroff mode: 0
LPM Persistent: 0

In particular, the “GOBIIM” flag is set which, according to the AT Command Reference, indicates an “image preference mismatch.” I’m not exactly sure what that means, although my immediate guess would be it has something to do with how I installed Legato (or flashed the firmware).

I cannot seem to find any information regarding this anywhere on the Web. I greatly appreciate any advice. Thank you much in advance.


#2

I had a similar issue. Let me know if this helps: http://forum.mangoh.io/t/wp7603-shutdown-loop/908/12


#3

Hi,

Can you show the following AT command response?

AT!entercnd="A710"
AT!gobiimpref?

Maybe there is PRI configuration mismatched.
How about going back to the previous FW (using one-click .exe file in Windows) which is working before?


#4

drewwestrick & jyijyi,

Thanks to your suggestions, I was able to fix the issue! I ended up resetting the user partition via swiflash (swiflash -m “WP85XX” -r) and reflashing the firmware with the Generic carrier “SWI9X15Y_07.12.09.00” Release 14 package (via the Windows EXE) from this page:
https://source.sierrawireless.com/resources/legato/wpfirmwarerelease/

Prior to reflashing, the following output was observed via AT!gobiimpref?:

preferred fw version:    07.12.09.00
preferred carrier name:  GENERIC
preferred config name:   GENERIC_001.033_000
current fw version:      07.12.09.00
current carrier name:    NONE
current config name:     NONE_000.000_000

carrier name mismatch
config name mismatch

After flashing, the output is now:

preferred fw version:    07.12.09.00
preferred carrier name:  GENERIC
preferred config name:   GENERIC_001.033_000
current fw version:      07.12.09.00
current carrier name:    GENERIC
current config name:     GENERIC_001.033_000

Furthermore, the command at!pcinfo? now displays its state as “Online” instead of “LowPowerMode.” It’s quite strange, I can’t imagine what I might have done to cause this. However, I’m glad it’s now fixed.

Thank you both very much for your assistance!


#5

Hi,
I have the same issue on WP7502 but firmware reflashing doesn´t help. I tried flashing of combined images FW13.1 and FW14. I tried both ways: flashing from windows (EXE utility) and from native linux (swiflash utility).
Name of preferred carrier/config name is changing but current carrier/config name is still NONE.

!IMPREF:
preferred fw version: 07.11.22.00
preferred carrier name: GENERIC
preferred config name: GENERIC_001.032_000
current fw version: 07.11.22.00
current carrier name: NONE
current config name: NONE_000.000_000

carrier name mismatch
config name mismatch

OK

This issue has started after I erased user partition (restore root file system) by recovery wizard in Developer Studio.

Have you please any suggestion?
Thanks.


#6

Follow the below steps hope it will help:
at!gobiimpref?
!GOBIIMPREF:
preferred fw version: 07.11.22.00
preferred carrier name: GENERIC
preferred config name: GENERIC_001.032_000
current fw version: 07.11.22.00
current carrier name: NONE
current config name: NONE_000.000_000
OK

carrier name mismatch
config name mismatch

at!unlock="A710"
OK

at!gobiimpref=“07.11.22.00”,“GENERIC”,"GENERIC_001.032_000"
OK

at!reset
OK

Command:
at!gobiimpref=“current fw version”,“GENERIC”,“current config name”

It should be Online Now !

Thnx


#7

I don’t know what else to do. I have done everything I’ve read on this post, but I cannot start radio. I think my problem starte when I upgraded form 16.10.1 to 16.10.3 but i’m not pretty sure.
I have read almost all AT command document, I have tried lots of combinations, different SIMs, modules…etc. I also downgraded to 16.10.1. Any suggestions??


#8

Unfortunately, it doesn’t work. I has tried suggested commands and it seems that my WP7502 uses other set of commands. Command at!unlock=“A710” is unknown and at!gobiimpref= works only with one parameter “GENERIC”. You can see this in log. What else can I try?

[2018-02-13 22:43:41:426_S:] at!gobiimpref?
[2018-02-13 22:43:41:429_R:] at!gobiimpref?
[2018-02-13 22:43:41:441_R:] !GOBIIMPREF:
[2018-02-13 22:43:41:441_R:] preferred fw version: 07.12.09.00
[2018-02-13 22:43:41:441_R:] preferred carrier name: GENERIC
[2018-02-13 22:43:41:441_R:] preferred config name: GENERIC_001.033_000
[2018-02-13 22:43:41:441_R:] current fw version: 07.12.09.00
[2018-02-13 22:43:41:441_R:] current carrier name: NONE
[2018-02-13 22:43:41:441_R:] current config name: NONE_000.000_000

[2018-02-13 22:43:41:441_R:] carrier name mismatch
[2018-02-13 22:43:41:441_R:] config name mismatch

[2018-02-13 22:43:41:441_R:] OK
[2018-02-13 22:43:47:024_S:] at!unlock=“A710”
[2018-02-13 22:43:47:027_R:] at!unlock=“A710”

[2018-02-13 22:43:47:032_R:] ERROR
[2018-02-13 22:43:49:322_S:] at!entercnd=“A710”
[2018-02-13 22:43:49:325_R:] at!entercnd=“A710”

[2018-02-13 22:43:49:330_R:] OK
[2018-02-13 22:44:10:522_S:] at!gobiimpref=“07.12.09.00”,“GENERIC”,“GENERIC_001.033_000”
[2018-02-13 22:44:10:527_R:] at!gobiimpref=“07.12.09.00”,“GENERIC”,“GENERIC_001.033_000”

[2018-02-13 22:44:10:529_R:] ERROR
[2018-02-13 22:44:23:022_S:] at!gobiimpref=“GENERIC”
[2018-02-13 22:44:23:025_R:] at!gobiimpref=“GENERIC”

[2018-02-13 22:44:23:110_R:] OK
[2018-02-13 22:44:29:795_S:] at!reset
[2018-02-13 22:44:29:798_R:] at!reset

[2018-02-13 22:44:29:810_R:] OK

[2018-02-13 22:48:22:655_R:] (DSR:1) CTS:1 RI:0 DCD:1
[2018-02-13 22:48:34:678_S:] at!gobiimpref?
[2018-02-13 22:48:34:681_R:] at!gobiimpref?

[2018-02-13 22:48:34:698_R:] !GOBIIMPREF:
[2018-02-13 22:48:34:698_R:] preferred fw version: 07.12.09.00
[2018-02-13 22:48:34:698_R:] preferred carrier name: GENERIC
[2018-02-13 22:48:34:698_R:] preferred config name: GENERIC_001.033_000
[2018-02-13 22:48:34:698_R:] current fw version: 07.12.09.00
[2018-02-13 22:48:34:698_R:] current carrier name: NONE
[2018-02-13 22:48:34:698_R:] current config name: NONE_000.000_000

[2018-02-13 22:48:34:698_R:] carrier name mismatch
[2018-02-13 22:48:34:698_R:] config name mismatch

[2018-02-13 22:48:34:698_R:] OK


#10

Hi,

Updating the complete package will update the PRI and modem will be online.
But if level 3 unlock is mandatory, maybe better to ask the Sierra Sales/FAE to generate it.

Thanks.


#11

Hi,
thanks for suggestion. But it is still the same.
I have flashed Firmware package release 15. Current carrier PRI is still NONE. Response to AT commands is similar like it was before flash. See log bellow.
Link to suggested Jenkins job doesn’t work for me. Do You thing that level 3 unlock could help?

[2018-02-20 20:27:12:373_R:] at!gobiimpref?

[2018-02-20 20:27:12:384_R:] !GOBIIMPREF:
[2018-02-20 20:27:12:384_R:] preferred fw version: 07.12.14.00
[2018-02-20 20:27:12:384_R:] preferred carrier name: GENERIC
[2018-02-20 20:27:12:384_R:] preferred config name: GENERIC_001.034_000
[2018-02-20 20:27:12:384_R:] current fw version: 07.12.14.00
[2018-02-20 20:27:12:384_R:] current carrier name: NONE
[2018-02-20 20:27:12:384_R:] current config name: NONE_000.000_000

[2018-02-20 20:27:12:384_R:] carrier name mismatch
[2018-02-20 20:27:12:384_R:] config name mismatch

[2018-02-20 20:27:12:384_R:] OK
[2018-02-20 20:27:21:195_S:] at!unlock=“A710”
[2018-02-20 20:27:21:198_R:] at!unlock=“A710”

[2018-02-20 20:27:21:203_R:] ERROR
[2018-02-20 20:27:23:952_S:] at!entercnd=“A710”
[2018-02-20 20:27:23:956_R:] at!entercnd=“A710”

[2018-02-20 20:27:23:972_R:] OK
[2018-02-20 20:27:32:305_S:] at!gobiimpref=“07.12.14.00”,“GENERIC”,“GENERIC_001.034_000”
[2018-02-20 20:27:32:310_R:] at!gobiimpref=“07.12.14.00”,“GENERIC”,“GENERIC_001.034_000”

[2018-02-20 20:27:32:314_R:] ERROR
[2018-02-20 20:27:35:664_S:] at!gobiimpref=“GENERIC”
[2018-02-20 20:27:35:668_R:] at!gobiimpref=“GENERIC”

[2018-02-20 20:27:35:830_R:] OK

[2018-02-20 20:27:49:040_S:] at!reset
[2018-02-20 20:27:49:043_R:] at!reset

[2018-02-20 20:27:49:054_R:] OK

[2018-02-20 21:09:24:720_R:] DSR:0 (CTS:1) RI:0 DCD:1

[2018-02-20 21:09:24:721_R:] (DSR:1) CTS:1 RI:0 DCD:1
[2018-02-20 21:09:31:389_S:] at!gobiimpref?
[2018-02-20 21:09:31:393_R:] at!gobiimpref?

[2018-02-20 21:09:31:409_R:] !GOBIIMPREF:
[2018-02-20 21:09:31:409_R:] preferred fw version: 07.12.14.00
[2018-02-20 21:09:31:409_R:] preferred carrier name: GENERIC
[2018-02-20 21:09:31:409_R:] preferred config name: GENERIC_001.034_000
[2018-02-20 21:09:31:409_R:] current fw version: 07.12.14.00
[2018-02-20 21:09:31:409_R:] current carrier name: NONE
[2018-02-20 21:09:31:409_R:] current config name: NONE_000.000_000

[2018-02-20 21:09:31:409_R:] carrier name mismatch
[2018-02-20 21:09:31:409_R:] config name mismatch

[2018-02-20 21:09:31:409_R:] OK


#12

Hi,

yes, better to ask the Sierra Sales/FAE to generate it.

Thanks.


#13

@liborsvehla : I would suggest you repeat the suggested sequence above entering first at!entercnd command and then at!unlock.
at!unlock should not give error then


#14

Hi all, I think there’s some confusion about the use of !GOBIIMPREF here. In the logs shown above, the current preference is valid, and it’s the current image that’s showing NONE, which is causing the LPM vote. The attempts to use GOBIIMPREF to set the preference, as shown above, would only set the preference to the same value it’s already set to, rather than actually changing the current version.

There are a few reasons the system can be in this state. The main one is that an image switch to the preferred image is prevented if the preferred configuration (combination of FW, carrier, and carrier config version) is not present on the system. When you load an official release package, that should guarantee that the configuration is available. Evidently that isn’t happening. The following command is not officially published, but I’m going to put in a request to add this to external documentation. It requires Level 2 unlock (AT!ENTERCND=“A710”):
On my system:
at!image?
TYPE SLOT STATUS LRU FAILURES UNIQUE_ID BUILD_ID
FW 1 EMPTY 0 0 0
FW 2 EMPTY 0 0 0
FW 3 EMPTY 0 0 0
Max FW images: 2
Active FW image is at slot 255

TYPE SLOT STATUS LRU FAILURES UNIQUE_ID   BUILD_ID
PRI  FF   GOOD   0   0 0      001.034_000 07.12.14.00_GENERIC
Max PRI images: 50

OK

I am not using slots for Modem images, at the moment, so mine are empty. And the only carrier configuration I have loaded is the Generic as shown. You can use this command to check if the configuration in your preference is actually available. Can you provide the output from that command? A few other general health checks that might help diagnose: AT!PRIID? AT!PACKAGE?. These will confirm that the main configuration components are still valid. If this doesn’t help, I realize this is an older thread, but I wonder if you can pinpoint what upgrade path or action triggered this issue, to help debug further.


#15

Hi, it seems that a preferred image is installed. Just current package differs. Please see log bellow. What can I do with this?

[2018-03-19 18:25:48:540_S:] at!image?
[2018-03-19 18:25:48:543_R:] at!image?

[2018-03-19 18:25:48:656_R:] TYPE SLOT STATUS LRU FAILURES UNIQUE_ID BUILD_ID
[2018-03-19 18:25:48:656_R:] FW 1 EMPTY 0 0 0
[2018-03-19 18:25:48:656_R:] FW 2 EMPTY 0 0 0
[2018-03-19 18:25:48:656_R:] FW 3 EMPTY 0 0 0
[2018-03-19 18:25:48:656_R:] Max FW images: 3
[2018-03-19 18:25:48:656_R:] Active FW image is at slot 255

[2018-03-19 18:25:48:656_R:] TYPE SLOT STATUS LRU FAILURES UNIQUE_ID BUILD_ID
[2018-03-19 18:25:48:656_R:] PRI FF GOOD 0 0 0 001.034_000 07.12.14.00_GENERIC
[2018-03-19 18:25:48:656_R:] Max PRI images: 50

[2018-03-19 18:25:48:656_R:] OK
[2018-03-19 18:25:55:575_S:] at!gobiimpref?
[2018-03-19 18:25:55:578_R:] at!gobiimpref?

[2018-03-19 18:25:55:595_R:] !GOBIIMPREF:
[2018-03-19 18:25:55:595_R:] preferred fw version: 07.12.14.00
[2018-03-19 18:25:55:595_R:] preferred carrier name: GENERIC
[2018-03-19 18:25:55:595_R:] preferred config name: GENERIC_001.034_000
[2018-03-19 18:25:55:595_R:] current fw version: 07.12.14.00
[2018-03-19 18:25:55:595_R:] current carrier name: NONE
[2018-03-19 18:25:55:595_R:] current config name: NONE_000.000_000

[2018-03-19 18:25:55:595_R:] carrier name mismatch
[2018-03-19 18:25:55:595_R:] config name mismatch

[2018-03-19 18:25:55:595_R:] OK
[2018-03-19 18:26:09:796_S:] AT!PRIID?
[2018-03-19 18:26:09:800_R:] AT!PRIID?

[2018-03-19 18:26:09:877_R:] PRI Part Number: 9906352
[2018-03-19 18:26:09:877_R:] Revision: 01.05

[2018-03-19 18:26:09:877_R:] Carrier PRI: 9999999_9904559_SWI9X15Y_07.12.14.00_00_GENERIC_001.034_000

[2018-03-19 18:26:09:877_R:] OK
[2018-03-19 18:26:16:257_S:] AT!PACKAGE?
[2018-03-19 18:26:16:260_R:] AT!PACKAGE?

[2018-03-19 18:26:16:273_R:] 1103114_9906352_WP7502_07.11.22.00_00_Generic_001.005_000

[2018-03-19 18:26:16:273_R:] OK

This is the history of the problem:
This modem was bought with WPFirmwareRelease13.1 and radio worked fine.
This issue started after flashing procedure failure. The aim was upgrade to WPFirmwareRelease14 but windows flashing utility has frozen during flashing process. I restarted the modem but it got stuck at boot sequence and continuously restarted. I did recovery process and cleared user partition. Then I flashed WPFirmwareRelease14 successfully. But there is “Image Preference Mismatch” since this time.
Also an issue with GPIO settings revealed. Nearly all of them were under modem control. I switched them under user space control. So GPIO issue is solved. But “Image Preference Mismatch” persists.

Thank you for your assistance.


#16

A small update after investigating @liborsvehla’s device off-thread: we found that the customization “GOBIIMEN” was disabled on his device, which prevented the modem from applying the image preference, resulting in the device becoming stuck in LPM. I provided a small SPK file that “patched” his configuration for that item, which recovered normal operation.

If anyone else observes the same issue (confirmed by “GOBIIMEN” not shown in the AT!CUSTOM? response), please feel free to post or contact me directly for assistance.

Thanks @liborsvehla for taking the time to debug this.

Ryan