WP76xx R8 Yocto linux does not build correctly


#1

Trying to make a custom image, but first trying the R8 version of Yocto source to build, does not build correctly. It errors out. A second attempt (making no changes), claims to have finished with no build, but is not the same size as the original, not to mention the binary differences. It’s at least 500 bytes less.


#2

Hi @EvetsMostel,

could you provide some logs? It is hard to figure out what the problem is without them.


#3

Hi @CoRfr,
Apparently, this only happens when you first untar the file and try to build it. I did this twice (for other reasons) and I got the issue both times. If you just do a clean and build it doesn’t happen. Since it takes a long time to build it on my VM, I will try to do it tonight and let you know tomorrow.

Evets


#4

Hi @CoRfr,
Apparently, third times a charm? Definitely had this problems, the first two times I did it. This time though, no errors, just 39 warnings. Not sure why that would be. Each time I deleted the entire yocto directory and extracted the tar file the same way. Go Figure. I will compare the .cwe files though to see that they are the same size. That was really my biggest concern anyway.

After comparing the linux-SWI9x07Y_02.14.04.00.cwe to my yocto_wp76xx.4k.cwe, I am again missing about 500K bytes. What is going on?

Evets


#5

Could you post a swicwe -P on both files?


#6

Hi @CoRfr ,

swicwe -P linux-SWI9X07Y_02.14.04.00.cwe
Type Size(Exclude Header) Product Compress Version
*APPL 29642568 Y921 0 SWI9X07Y_02.14.04.00 000000 jenkins 2018/02/14 22:59:27
APBL 529704 9X28 0 SWI9X07Y_02.14.04.00 000000 jenkins 2018/02/14 22:59:27
SYST 19922944 9X28 0 SWI9X07Y_02.14.04.00 000000 jenkins 2018/02/14 22:59:27
APPS 9188720 9X28 0 SWI9X07Y_02.14.04.00 000000 jenkins 2018/02/14 22:59:27

swicwe -P yocto_wp76xx.4k.cwe
Type Size(Exclude Header) Product Compress Version
*APPL 29116560 Y921 0 SWI9X07Y_02.14.04.00 2018/03/13 22:56:41
SYST 19922944 9X28 0 SWI9X07Y_02.14.04.00 2018/03/13 22:56:41
APPS 9192816 9X28 0 3.18.20+gitdd8fe1c7affdfb324e1b5db7701dbb69af46a8ec 20180313232734

Appears to be missing the APBL section, among other things.


#7

The rootfs size (SYST) is exactly the same, and the kernel size (APPS) is extremely close (diff = 4096, so it might have been just a small diff in size that eventually took one more sector).
What’s really different in your cwe is that lk (=apps bootloader, APBL) is not in there, and that should not be considered as an issue, you can eventually package it in it through swicwe if you do not want to keep the stock lk.


#8

But should not not be the same? I downloaded the source, untared it and did a make image. Shouldn’t that get EXACTLY what is released via download? Otherwise, in Dev Studio, when you build a custom image it would be missing, and so not everything would be in sync with the current release. I shouldn’t have 4K missing. I can see small differences in bytes due to time/date being involved in the compilations, but 4K in size? That’s Never been a good thing in any product I’ve worked on.


#9

Hi,

We tried with the latest release R8. and also downloaded the yocto release with the SWI9X07Y_02.14.04.00 Source but We have not face any compilation and build error.both compile/build was successful.

after extracting SWI9X07Y_02.14.04.00 Source we got “yocto” and we gave make.
We got error.later once again We gave make .it was building successful.


#10

Right. That is what I saw. It would give an error the first time, then if you did ‘make image’ a second time without doing anything else, it would complete. However, it is not the same size as the image downloaded from Sierra’s Source. It is missing the boot image, but the total size of the other images aren’t the same. about 4K less, which is disturbing. Can you verify the images you got, and why isn’t the bootloader in there?


#11

Hello - I can respond regarding the absence of the LK bootloader. The omission of the LK image from the yocto_wp76xx.4k.cwe is intentional in the WP76xx series, but feedback seems to be trending towards adding it back to a combined CWE again, as was done for WP8548/WP75xx. We’re tracking that feedback, but I’m not sure it’s reached consensus yet. I think we could add a new combined CWE without removing any of the existing CWE files though, which should give everyone the option they need.

The other problem, though, is that the standalone LK CWE file (appsboot_wp76xx.cwe) generated by the build has a Y922 product ID, which is for a deprecated model of the WP76xx with 2K page size flash. Fortunately, the MBN format of the LK is the same regardless of flash, so with some repackaging, you can still get a familiar CWE with LK, Kernel, and Rootfs, if desired. From build_bin/tmp/deploy/images/swi-mdm9x28/:
swicwe --ACWE --pid Y921 --lk appsboot.mbn --rootfs mdm9x28-image-minimal-swi-mdm9x28.4k.default --kernel boot-yocto-mdm9x28.4k.img -o boot-yocto_wp76xx.4k.cwe

This is not something we intend to impose on users going forward. It’s scheduled to be improved for Release 9. Sorry for the inconvenience.