Can't use manifest for release 17 WP76xx


Release 17 for WP76xx is now available for download and can be obtained using Leaf.
I would like to use the manifest file from GitHub - legatoproject/manifest: repo manifests for Legato , however i cannot sync products/wp76xx/releases/Release17.xml. There are multiple tags missing in other repo’s reffered to.

Maybe someone has forgotten to push something?

just a suggestion, you can use the yocto source here:

We can compile it:

Thank you for your suggestion.
Currently we are working with other projects using repo and manifest files. So I would like to have the same flow in all mine projects if possible.

Could someone from the developers push the missings changes?

quick question, have you contacted distributor on this?
It would be better to get a fix there.

BTW, do you mean you are seeing these error message?

owner@CNHKG-EX-001367:~/git_test_WP76_R17$ python3 repo init -u ssh:// -m products/wp76xx/releases/Release17.xml -g default,-cache,proprietary

... A new version of repo (2.35) is available.
... You should upgrade soon:
    cp /home/owner/git_test_WP76_R17/.repo/repo/repo /home/owner/git_test_WP76_R17/repo

repo: reusing existing repo client checkout in /home/owner/git_test_WP76_R17
Enter passphrase for key '/home/owner/.ssh/id_ecdsa': 

repo has been initialized in /home/owner/git_test_WP76_R17
owner@CNHKG-EX-001367:~/git_test_WP76_R17$ python3 repo sync

... A new version of repo (2.35) is available.
... You should upgrade soon:
    cp /home/owner/git_test_WP76_R17/.repo/repo/repo /home/owner/git_test_WP76_R17/repo

Enter passphrase for key '/home/owner/.ssh/id_ecdsa': 
Fetching:  0% (0/62) 0:05 | 5 jobs | 0:04 msm-4.14 @ kernel
fatal: Couldn't find remote ref refs/tags/22.10.0.ThreadX.rc1

fatal: Couldn't find remote ref refs/tags/22.10.0.ThreadX.rc1
tinydtls: sleeping 4.0 seconds before retrying
fatal: Couldn't find remote ref refs/tags/22.10.0.ThreadX.rc1

fatal: Couldn't find remote ref refs/tags/22.10.0.ThreadX.rc1
error: Cannot fetch tinydtls from

fatal: Couldn't find remote ref refs/tags/20.09.0.rc1

fatal: Couldn't find remote ref refs/tags/20.09.0.rc1
legato-3rdParty-libcbor: sleeping 4.0 seconds before retrying
fatal: Couldn't find remote ref refs/tags/20.09.0.rc1

fatal: Couldn't find remote ref refs/tags/20.09.0.rc1

fatal: Couldn't find remote ref refs/tags/21.01.0.FreeRTOS.rc1

yes that’s correct. like stated in the issue on the github page of legato: Can’t sync products/wp76xx/releases/Release17.xml (missing tags) · Issue #14 · legatoproject/manifest · GitHub

OK, I have reported this issue internally

As a workaround now, please download the one in SOURCE website to start your development.
We will let you know once it is fixed.

1 Like


I see that Adam Lin has pushed a commit “Fix WP76 release17 and legato 21.05.2.rc2 manifest”. That’s a good sign. He has unfortunately not pushed the tags of all the other repo’s to “refs/tags/21.05.2.rc2”.

Could you be so kind and get this fixed?

21.05.2.rc2 seems to be aninternal tag that cannot push to external.
We are still trying to fix this ( maybe create a new tag…)

Can you try at your side?
It seems to be OK now.
Below is the log:

WP76R17_logs.txt (338.0 KB)

Thank you for you time and update.

Unfortunately i am getting a different outcome when running the same command
./../repo1 init -u ssh:// -m products/wp76xx/releases/Release17.xml -g default,-cache; repo sync

I get a new user error when i want to attach a file.
Thus you can download my log here: until 26th jan

can you create a new folder and try with this repo:

curl -o repo

the last repo doesn’t work.
It fails with

Fetching: 100% (62/62), done in 3m3.395s
Updating files: 100% (66521/66521), done.les:  42% (27939/66521)
error: Cannot checkout msm-4.14: ManifestInvalidPathError: /home/user/projects/sierra/release17/kernel/arch/arm/mach-msm: traversing symlinks not allow
Checking out:  48% (30/62), done in 6.135s
error: in `sync`: /home/user/projects/sierra/release17/kernel/arch/arm/mach-msm: traversing symlinks not allow

which version did you use?

oke, somehow it works now with the other repo version you have posted somewhere on this forum.
It is the same repo1 that is used in my previous post.
See attached output.

I wil try to build it with the commands:

make dev

unfortunately the build fails with:

ERROR: mdm9x28-image-minimal-1.0-r0.0 do_image: Error executing a python function in exec_func_python() autogenerated:

The stack trace of python calls that resulted in this exception/failure was:
File: 'exec_func_python() autogenerated', lineno: 2, function: <module>
 *** 0002:do_image(d)
File: '/home/user/projects/sierra/release17/poky/meta/classes/image.bbclass', lineno: 263, function: do_image
     0260:    d.setVarFlag('REPRODUCIBLE_TIMESTAMP_ROOTFS', 'export', '1')
     0261:    pre_process_cmds = d.getVar("IMAGE_PREPROCESS_COMMAND")
 *** 0263:    execute_pre_post_process(d, pre_process_cmds)
     0265:do_image[dirs] = "${TOPDIR}"
     0266:do_image[umask] = "022"
     0267:addtask do_image after do_rootfs
File: '/home/user/projects/sierra/release17/poky/meta/lib/oe/', lineno: 264, function: execute_pre_post_process
     0260:    for cmd in cmds.strip().split(';'):
     0261:        cmd = cmd.strip()
     0262:        if cmd != '':
     0263:            bb.note("Executing %s ..." % cmd)
 *** 0264:  , d)
     0266:# For each item in items, call the function 'target' with item as the first
     0267:# argument, extraargs as the other arguments and handle any exceptions in the
     0268:# parent thread
File: '/home/user/projects/sierra/release17/poky/bitbake/lib/bb/', lineno: 254, function: exec_func
     0250:    with bb.utils.fileslocked(lockfiles):
     0251:        if ispython:
     0252:            exec_func_python(func, d, runfile, cwd=adir)
     0253:        else:
 *** 0254:            exec_func_shell(func, d, runfile, cwd=adir)
     0256:    try:
     0257:        curcwd = os.getcwd()
     0258:    except:
File: '/home/user/projects/sierra/release17/poky/bitbake/lib/bb/', lineno: 455, function: exec_func_shell
     0451:    with open(fifopath, 'r+b', buffering=0) as fifo:
     0452:        try:
     0453:            bb.debug(2, "Executing shell function %s" % func)
     0454:            with open(os.devnull, 'r+') as stdin, logfile:
 *** 0455:      , shell=False, stdin=stdin, log=logfile, extrafiles=[(fifo,readfifo)])
     0456:        finally:
     0457:            os.unlink(fifopath)
     0459:    bb.debug(2, "Shell function %s finished" % func)
File: '/home/user/projects/sierra/release17/poky/bitbake/lib/bb/', lineno: 184, function: run
     0181:    if pipe.returncode != 0:
     0182:        if log:
     0183:            # Don't duplicate the output in the exception if logging it
 *** 0184:            raise ExecutionError(cmd, pipe.returncode, None, None)
     0185:        raise ExecutionError(cmd, pipe.returncode, stdout, stderr)
     0186:    return stdout, stderr
Exception: bb.process.ExecutionError: Execution of '/home/user/projects/sierra/release17/build_bin/tmp/work/swi_mdm9x28_wp-poky-linux-gnueabi/mdm9x28-image-minimal/1.0-r0.0/temp/run.do_generate_version_file.1052324' failed with exit code 128

ERROR: Logfile of failure stored in: /home/user/projects/sierra/release17/build_bin/tmp/work/swi_mdm9x28_wp-poky-linux-gnueabi/mdm9x28-image-minimal/1.0-r0.0/temp/log.do_image.1052324
ERROR: Task (/home/user/projects/sierra/release17/meta-swi/meta-swi-mdm9x28/recipes-core/images/ failed with exit code '1'
NOTE: Tasks Summary: Attempted 4132 tasks of which 10 didn't need to be rerun and 1 failed.

Are you able to compile the r17 yocto source downloaded from

yes i can compile the tar.
The last time i did is a few months back. I will try to validate correct build right now.

Ah, extracting the tar and building with make dev; exit; make; also fails. I will investigate this further

It turns out that i cannot build the tar nor the manifest file any more.
I have tried it with Ubuntu 20.04,18.04 and 16.04 both in Docker and directly on hardware. I keep getting the same error on all setups.

Would like to know what i am missing. Can you tell me the dependencies you are using?

See below for the Docker file I am using:

FROM ubuntu:bionic

ENV DEBIAN_FRONTEND=noninteractive

RUN ln -snf /usr/share/zoneinfo/$TZ /etc/localtime && echo $TZ > /etc/timezone

RUN apt-get update
RUN apt-get install -y tzdata

RUN apt-get update && apt-get install -y gawk wget git-core diffstat unzip \
             texinfo gcc-multilib build-essential chrpath socat cpio python python-jinja2 \
             python3 python3-pip python3-pexpect xz-utils debianutils iputils-ping \
             python3-git python3-jinja2 python3-protobuf libegl1-mesa libsdl1.2-dev xterm locales \
             nano vim bash-completion screen apt-utils openjdk-17-jre-headless protobuf-compiler 

RUN apt-get update && apt-get install -y sudo \
#for legato:
RUN apt-get update &&       \
    apt-get install -y      \
    autoconf                \
    automake                \
    bash                    \
    bc                      \
    bison                   \
    bsdiff                  \
    build-essential         \
    chrpath                 \
    cmake                   \
    cpio                    \
    diffstat                \
    flex                    \
    gawk                    \
    gcovr                   \
    git                     \
    gperf                   \
    iputils-ping            \
    libbz2-dev              \
    libcurl4-gnutls-dev     \
    libncurses5-dev         \
    libncursesw5-dev        \
    libsdl-dev              \
    libssl-dev              \
    libsystemd-dev          \
    libtool                 \
    libxml2-utils           \
    ninja-build             \
    python                  \
    python-jinja2           \
    python-pkg-resources    \
    python3                 \
    texinfo                 \
    unzip                   \
    wget                    \

RUN wget -O /tmp/swiflash_latest.deb \
         && apt install -y /tmp/swiflash_latest.deb
RUN wget -O /tmp/swicwe_latest.deb \
         && apt install -y /tmp/swicwe_latest.deb
RUN wget \
         -O /tmp/ \
         && chmod +x /tmp/ \
         && /tmp/ -y
RUN mkdir /not && ln -s /opt/swi/SWI9X07Y_03.01.07.00/sysroots/armv7a-neon-poky-linux-gnueabi /not/exist

# use bash instead of sh
RUN echo "dash dash/sh boolean false" | debconf-set-selections
RUN DEBIAN_FRONTEND=noninteractive dpkg-reconfigure dash

## vscode user
RUN apt-get install -y curl

RUN groupadd -g ${PGID} ${USERNAME} \
            && useradd -u ${PUID} -g ${USERNAME} -d /home/${USERNAME} ${USERNAME} \
            && mkdir -p /home/${USERNAME}/projects \
            && chown -R ${USERNAME}:${USERNAME} /home/${USERNAME}
## vscode user

RUN locale-gen en_US.UTF-8


COPY ./bashrc /home/${USERNAME}/.bashrc


how about building the yocto image of FW R16.0.1?,-d-,0,-d-,1-components/#sthash.KFGymtuk.X461OstI.dpbs