WP76xx - Ignore OPLMN


Our product uses Sim Cards that have an OPLMN list, which gets the modem to sometimes pick a lower quality network than it would have without this list.

I’ve tried to remove it using AT+CPOL (not allowed) as well as modifying / updating file 6F61 (not allowed either).

Is there any method to let the modem pick the network without being influenced by the OPLMN and without having to set a UPLMN list?


have you tried to use manually mode of AT+COPS to set the PLMN which you want?


Yes, using AT+COPS works well but it needs knowing which network to chose from, which will not be always the same depending on where the product is deployed.

The issue I have is that I don’t know which network will be best and I prefer the modem to use the automatic selection as depicted by 3GPP, randomly picking a “high quality” network (at least -110 dBm RSRP).

The OPLMN list works against that as I can see it can favour a network that is not part of the “high quality” networks.

what is “AT+CPLS?” for Selection of Preferred PLMN list?

CPLS would allow to select which list would be manipulated when using CPOL.
AT+CPLS=0 allows to read and write the UPLMN
AT+CPLS=1 allows to read the OPLMN, but write is forbidden.

If this is set by operator, i don’t think you can write the oplmn.

Did you contact the network operator?

Yes, I’ve contacted them. So far they haven’t been able to give me a clear answer, so I thought I’d try here as well just in case.

If you set +cpls to 0, and then modify the +cpol, is this working?

The priority of user plmn list should higher than operator plmn list

This was the method suggested by Twilio, the sim provider.

The issue is that it’s the same problem as the one I have with the OPLMN: I don’t know which network is going to be the best in advance, and I prefer to let the modem pick the strongest.

It will first choose home plmn and then user plmn, and then opertor plmn, and then if there is such plmn, it will register to the best signal quality plmn.
So you need to change the sim without the operator plmn list

So you confirm that there is no possible way to ignore or erase the OPLMN?
Changing sim is not completely an option just now unfortunately

You should ask the operator how to erase it

Thanks for your help.

They’ve been telling me to ask the product vendor how to do it. I’ll keep looking then.

Hello Ben,
Have you got any workaround to disable the OPLMN in Twilio?

Hello @tamilarasan.r ,

Yes. I stopped using the automated network selection and instead perform a scan, then connect to each network nearby to get more data on their quality then choose the best one.
For that I’m using various legato function (to scan, extract data, connect) for which you’ll find examples here: Sample code for Network Scan - Legato Docs (that one is only for scanning but you’ll see other examples in the same documentation section if you need them)

Unfortunately I didn’t find a simpler way!

@ben1 Thanks for the quick reply : )
I’ll try this out.