Ubuntu Linux developer PC - apt-get can't reach web resource


#1

Hi

This is almost certainly me not understanding Linux development machines properly and sorry if this has already been answered.

But does anyone know how to fix the following issue
When the mangoh (15-10) board is connected to a Linux development PC via USB – and USB0 and WLAN network devices are present on the development PC (WLAN not connected – no SIM for WP85) - I have noticed that apt-get can’t reach web resources.
If I unplug the mangoh apt-get works fine.
What is the best way to work around this issue?

Thanks

John


#2

I have struggled with the same issue on both Windows and Linux . But I have found a solution.

On Ubuntu:
Go into
network setting
select the ECM connection to the WP
options
IPV4 setting
routes
check “Use this connection only for resources on its network”


#3

Thanks - it didn’t work for me

On Ubuntu host:
network setting
Edit Connections
Edit (you have to find the Wired Connection which represents USB0 this is the WP85)
IPV4 Settings
Method: Link-Local Only

Doesn’t work either (allows Host PC network web access but can’t connect to WP85)


#4

I have attached a screenshot.

If that is not possible for you I guess you need to use the “route” command to change the default route.


#5

ah that’s interesting - which version of Ubuntu are you running? I’m using 15.04

Also I notice that on your view there is an airplane on/off switch - I don’t have that. Also on my system USB0 (the WP85 ) is using the the cdc ether driver - I wonder if your OS has a different driver.

I can’t see why the setting you suggest doesn’t work on my system though


#6

I use Ubuntu 12.04.

But it might be the driver. I use the CDC_ECM driver. To use that driver instead you have to run this command locally on the WP8548:


#7

Good idea but unfortunately my system is set the same

root@swi-mdm9x15:~# configEcm show
target.ipV4: 192.168.1.2
host.ipV4: 192.168.1.3
netmask.ipV4: 255.255.255.0
DONE


#8

Then it is Ubuntu 15.04. I did test Ubuntu 14.04 in VM and it has the same options as in 12.04.

If nothing else works I guess you need to use the “route” command to set the default route.


#9

I had the same issue on Windows.
I solved it when I set on the LAN of the host pc the IP 192.168.1.3 as static, as you can on the attached pic


#10

This was an issue with how we had configured the DHCP server on the WP85 - it is fixed if you update to the latest.

Alternatively, you can use a fixed IP as described above or …

if you want to fix this on a device without updating you have then put the two lines below in /etc/dnsmasq.ecm.conf (assuming you have one)

dhcp-option=3
dhcp-option=6

Or …
Annoyingly the forum won’t let me add the actual files with a suffix of .conf, so I have put “.txt” on the end. You can put these files (without .txt) in /etc and restart. That should fix it.