Suspending console(s) (use no_console_suspend to debug)


#1

Hello,

when I don’t connect my MangoH Board via USB to my PC, the UART Console is suspeding.
How can I avoid that?

.
.
[ 18.882771] adb_open
[ 18.892049] IPv6: ADDRCONF(NETDEV_UP): usb0: link is not ready
Starting tcf-agent: OK
Starting linkmon: [ 19.324950] mbim_open: Open mbim driver
[ 19.327788] mbim_open: Lock mbim_dev->open_excl for open
done
[ 19.344758] mbim_open: USB cable not connected
[ 19.348176] mbim_open: Exit, mbim file opened
[ 19.386754] mbim_read: Requests list is empty. Wait.
run_getty.sh: UART2 (=/dev/ttyHS0) reserved for CONSOLE

Poky (Yocto Project Reference Distro) 1.7.3 swi-mdm9x15 /dev/ttyHSL1

swi-mdm9x15 login: No lease, forking to background

Poky (Yocto Project Reference Distro) 1.7.3 swi-mdm9x15 /dev/ttyHSL1

swi-mdm9x15 login: [ 24.794994] PM: Syncing filesystems … done.
[ 24.830398] Freezing user space processes …
[ 24.836777] mbim_read: Waiting failed
[ 24.852617] (elapsed 0.018 seconds) done.
[ 24.855608] Freezing remaining freezable tasks … (elapsed 0.001 seconds) done.
[ 24.863604] Suspending console(s) (use no_console_suspend to debug)
[ 24.876331] smsc95xx 1-1.3.1:1.0 eth0: entering SUSPEND2 mode
[ 24.883320] msm_hsic_host msm_hsic_host: HSIC-USB in low power mode
[ 24.883686] PM: suspend of devices complete after 12.086 msecs
[ 24.885792] PM: late suspend of devices complete after 2.075 msecs
[ 24.887654] PM: noirq suspend of devices complete after 1.831 msecs
[ 24.887868] msm_pm_enter
[ 24.887868] msm_pm_enter: power collapse
[ 24.887868] msm_mpm_irqs_detectable: cannot monitor 000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000,00000000
[ 24.887868] msm_pm_enter: return
[ 24.889302] PM: noirq resume of devices complete after 1.342 msecs
[ 24.891561] PM: early resume of devices complete after 1.556 msecs
[ 24.892812] msm_hsic_host msm_hsic_host: HSIC-USB exited from low power mode
[ 24.933801] PM: resume of devices complete after 42.209 msecs
[ 25.014680] Restarting tasks …
[ 25.023561] mbim_read: Requests list is empty. Wait.
[ 25.049717] done.
[ 25.050816] PM: Syncing filesystems … done.
[ 25.056096] Freezing user space processes …
[ 25.063604] mbim_read: Waiting failed
[ 25.067907] (elapsed 0.007 seconds) done.


#2

This happens when you use your mangOH with a DC power and USB configured as an ethernet interface.
I don’t know why but in this configuration the module enter in low power mode.

To solve this you can stop (or remove) the legato powerMgr application.


#3

There’s no other way to turn this off in the build?


#4

Hi ,
Please follow the below steps to disable the auto sleep mode on WP85.

  1. The first way (not persistent after a reboot) :
    To enable deep sleep, execute following shell command in console:
    echo mem > /sys/power/autosleep
    In current firmware by default the deep sleep mode is enabled, and keep in mind above command shall be executed upon every power cycling in order for deep sleep mode to be disabled.
    To disable deep sleep, execute following shell command in console:
    echo 0 > /sys/power/autosleep

  2. second way (persistent after a reboot) :
    update-rc.d -f enable_autosleep.sh remove
    (Re)activate it:
    update-rc.d enable_autosleep.sh start 99 S . stop 01 S .

  3. Third way :
    Comment out following line at “/etc/rcS.d/S99enable_autosleep.sh” on target.
    Enable the autosleep feature
    if [ -f /sys/power/autosleep ]
    then
    echo mem > /sys/power/autosleep
    true
    fi

The deep sleep mode is by default enabled from the release 10.1 (legato -af-16.01.2).

regards,
Hassan


#5

echo 0 > /sys/power/autosleep returns an error, use:
echo off > /sys/power/autosleep


#6

how about this error when type, please
/system/bin/sh: can’t create /sys/power/autosleep: Permission denied

omg i’m newbie, jus type su