AT Commands Server & UART

Hello all,

I am using AT Commands Server, for that I bind UART1 (!MAPUART=17,1). So I can send my own at commands to my application. It works well. But the issue is that UART1 goes into sleep mode after 5 s, even +KSLEEP is set 2. AT+KSLEEP=2 means Module never enters sleep mode.
Using UART1 as at command interface (!MAPUART=1,1), Module never enters sleep mode.
I using legato 19.07.0.
Does anyone have an idea how the issue can be solved?

How about this?

Probably power saving is activated, you can install devmode as a quick/dirty fix. Or add calls to power manager in your application and disable power saving mode trough legato commands.

Hello,
the advice of jyijyi solved my issue.
thanks.