Problems using at!usbcomp

Hi
I am working on wp7502 and wp7504.
I am trying to configure the usb interface such that only the ECM port is available on the PC.

According to the AT command reference i should use the following command.

at!entercnd=“A710”
at!usbcomp=1,1,00080001
(since the diag port cannot be disabled?)

but this fails with the message ERROR

is there anyone who have tried to run only with ECM and succeded? If yes, wat did you do to make it work?

Best regards
Kurt

Does this help?

Hi jyijiu

unfortunately not :frowning:
using using a bitmask with value 00080008 results in error.

I think that as soon I remove rmnet0 from the bitmask it fails.

(see my test results below)

Best regards

Kurt

I have tried the following bitmasks
00080101 (ecm, rmnet0, diag) works
00080111 (ecm, rmnet0, diag, at) works
00080109 (diag, modem, rmnet0, ecm) works
00080119 (diag, modem, at, rmnet0, ecm) works
00000101 (diag, rmnet0) works

00080000 dont work
00080001 dont work
00000009 dont work
00000001 dont work
00000004 dont work
00000005 dont work
00000008 dont work
00000009 dont work
00000010 dont work
00000101 dont work

I think you must keep DM and modem port.
Maybe the module has set to direct mode, so rmnet is needed.

Hi jyijyi

Do you know the commands where I can check the mode of the module ? I cannot find it in the AT command reference

Br

Kurt

Not sure if you can see by at!udpid? And AT!udpid=?

Seems like the devil is in the detail :slight_smile:

When reading the AT command reference it states that the only interface that cannot be disabled with the usbcomp command is the diag (DM) interface.

But when reading the “Deploying Your Devices For Deployment document” (section 2.3.2) it states that the dm interface must be enabled together with either AT, modem or Mbim must be enabled. My guess is that this now includes the RMNet interface.

Br
Kurt