Problems installing bundles (SOTA update)

Hi,

I have some issues with installing bundles to devices via AirVantage. I have tried using some different combinations with .app-files and binary files with various results. What I want to do is update the device using a differential update created using update-util.

I am interested in updating the overlay Legato system, not the other parts of the software/firmware.

When I compile my system using my own .sdef file, I get two files, which we can call:
system-v1.wp85.update
legatoz-v1.cwe

I also have a newer version of the software, which gives
system-v2.wp85.update
legatoz-v2.cwe

And using update-util,
update-util system-v1.wp85.update system-v2.wp85.update diff.wp85.update
I get a differential update file diff.wp85.update.

Using the command-line utils I can update the device via the USB without problems, I can e.g. first install system-v1.wp85.update and then diff.wp85.update and I will get the exact same version as if I installed system-v2.wp85.update directly.

However, via AirVantage I have more problems. I followed the step outlined in https://source.sierrawireless.com/resources/airprime/application_notes_and_code_samples/airprime_-wp_series-_airvantage_fota_sota_guidelines/. More specifically, section 8.1.2.2 describes the required format for the .app file, and I have used:

<?xml version="1.0" encoding="UTF-8"?> <app:application xmlns:app="http://www.sierrawireless.com/airvantage/application/1.0" type="FX30S" name="FX30S_my_system" revision="LE=16.10.1_0ee9b34fe7724c8b8f7d22ffe604d7af"> <binaries> <binary file="diff.wp85.update"/> </binaries> <application-manager use="LWM2M_LEGATO_BUNDLE" /> </app:application>
No matter what system update file I use, once I have issued the update via “Install bundle”, I immediately get the error [color=#FF0000]“Install application not supported on this system”[/color] Before it even starts to send the file to the device. Installing single apps to the device is no problem. I have made sure the revision in the app file is correct, i.e. matching what I expect to get from “legato version” for the updated version. What is the cause of this failure I get?

I noticed that there is a bundle provided by Sierra Wireless already present, which I can install using “Install bundle”, and the .app file for that contains

So I tried that using my own legatoz-v2.cwe, and changing the name and revision in the app file, and that works. However, if I instead use the .update files, either the full one or the diff file, it first downloads and installs the binary, but then fails with [color=#FF0000]“Upgrade failure [Integrity check failure for new downloaded package]”[/color]. I have made sure that the revision number is correct. I have tried two different .app files, both with the same error,

<?xml version="1.0" encoding="UTF-8"?> <app:application xmlns:app="http://www.sierrawireless.com/airvantage/application/1.0" type="FX30S" name="FX30S_my_system" revision="LE=16.10.1_0ee9b34fe7724c8b8f7d22ffe604d7af"> <binaries> <binary file="diff.wp85.update"/> </binaries> <application-manager use="LWM2M_AIRPRIME_BUNDLE" /> </app:application>

<?xml version="1.0" encoding="UTF-8"?> <app:application xmlns:app="http://www.sierrawireless.com/airvantage/application/1.0" type="FX30S" name="FX30S_my_system" revision="MDM=SWI9X15Y_07.11.22.00,CAPRI=9904559-001.032_000,CUPRI=1103232-001.000_000,LK=1.3.0_b12d0630d0,OS=3.14.29ltsi-a00e464379_c5f87a778d,RFS=SWI9X15Y_07.11.21.00 2017-04-19_15:57:04,UFS=unknown,LE=16.10.1_0ee9b34fe7724c8b8f7d22ffe604d7af,MCU=001.011"> <binaries> <binary file="diff.wp85.update"/> </binaries> <application-manager use="LWM2M_AIRPRIME_BUNDLE" /> </app:application>
I have also tried with system-v2.wp85.update instead of diff.wp85.update. What could be the cause of this error?

To my understanding, LWM2M_AIRPRIME_BUNDLE is part of AVC 2.0 introduced since Legato 17.05.
As seems you are using Legato 16.10, you should follow AVC 1.0 model.

Okay, so that probably explains why it does not work with my second method. How about LWM2M_LEGATO_BUNDLE, is that also part of AVC 2.0, or is it most likely some other reason for the failure using that value for application-manager? Is it at all possible to do a bundle update using AVC 1.0, or do I need to use AVC 2.0 for this?

Hi borisc
I got the same problem using AVC 2.0.
Did you ever get your own bundles working?

Hi @nilsa
did you achieve to solve your issue ?