Otg issue in R17, host mode does not work


I have a few questions regarding OTG. I found an article on the forum stating that it doesn’t work with custom hardware

We are facing the same issue here; we don’t have eth, and we also use LAN95XX. Is there any information available about this problem? Is there a solution for it, or will it be fixed at all? This is currently holding our project back.

Thank you for your responses!

this is regression on R17
Even for USB thumb drive, it would not work with the USB OTG.
As workaround, you might need to use R16 or route to USB host connector which is using HSIC bus.

We definitely need the 4.x kernel! We don’t have the option for an HSIC solution. Is there a way to configure the OTG USB to operate exclusively as a host?

Isn’t USB OTG always a host?
currently i cannot find any workaround to use USB OTG on R17

We have test build of R17 which is for fixing USB OTG.
I have tested with USB thumb drive, it is OK to read it:


Could you please provide me with a patch or a diff for the changes you made to enable OTG functionality? We are working on a custom build and would like to test it with these changes. Thank you in advance.

Best regards,

we are still testing the patch, we will attach the patch here later

In parallel, please test this yocto image at your side

We would be glad to test it, provided that we have a clear understanding of the modifications made in the “swi” package. Unfortunately, the project is currently stalled due to this, and we would like to proceed once it’s resolved.

I have tested the image you provided on our custom device, OTG is functioning, and the Ethernet interface is up and running. I look forward to further information. Thank you!

see if this patch works for you to apply to yocto source of R17:
usb_otg_fix.patch.txt (1.1 KB)

Thank you for providing the changes! I will report the information after testing.

Based on the results of the first round of tests, it works on our custom build. I’ll mark the comment as a solution if we find anything, I’ll inform you. Thanks for the patch!