Ntpd via cellular data connection

At the moment when I configure in /etc/time_service.conf to

TIME_SERVICES="ntpd_time" it doesn’t update system time when cellular data connection is established, it only works when eth connection is established. I tried using IP adress from pool.ntp.org.
Is there a way to make this work?

I am using 18.04 Legato on WP7702 and I don’t have AirVantage services installed, also my application is desired to be sandboxed, installed services are:

[running] atService
[running] cellNetService
[running] dataConnectionService
[running] fwupdateService
[running] gpioService
[running] modemService
[running] portService
[running] powerMgr
[running] secStore
[stopped] tools

I don’t want to use qcom_time because some providers that I have connected to didn’t provide correct time.


Try to replace “eth0” by “rmnet_data0” in these two scripts:

  • /etc/network/if-up.d/ntpd_start
  • /etc/network/if-down.d/ntpd_stop


Tahnks for your reply in the end I patched these files:
And added two scripts one in the

Added protection in the script to wait until the internet connection is established and then to reach for the time from ntp server. This solved my issue. Thanks