Nmea


#1

Hi team,

I would like to read nmea traces when I’m login inside the AR7, somebody knows how to do it?

I know there is a port in the target /dev/nmea which is loaded when the /etc/legato/usbmodes contains the nmea. Also, I set the gps configuration previously with the at command at!gpsfix=1,180,500 but nothing appears when I try cat /etc/nmea

What I am doing wrong?
Some missing step?

Thank you

Daniel


#2

Hi Daniel,

You have to echo “$GPS_START” into /dev/nmea

 echo "\$GPS_START" > /dev/nmea

and then read your nmea sentences from /dev/nmea

cat /dev/nmea

#3

Hi,

Thank you for your answer.

This is the ouput when I’ve tried to use the command:

root@swi-mdm9x15:~# echo "\$GPS_START" > /dev/nmea
[  111.611414] nmea_write failed to write 11 bytes: -1.
[  111.615382] nmea: smd opened
-sh: echo: write error: Input/output error

note: the /etc/legato/usbmodes contains the ‘nmea’ option so, the /dev/nmea is loaded correctly.

Thank you again,

Daniel


#4

Hi,

I had the same problem. It might be that your NMEA is turned off by default. You have to give a couple of AT commands to ensure that the NMEA will work.
http://legato.io/legato-docs/15_05/how_to_n_m_e_a.html

I hope it helps
Nick