Issue with update while updating CF3 module

Under the “Prepare your mangOH Red for Development” in the starter documentation (Linux) point 8 to install the mangOH Red platform there is command to update -

$ update ~/mangOH/build/update_files/red/mangOH.wp77xx.update 192.168.2.2

But after pressing enter it displays an error “update: at argument 2: Too many arguments”. Also there seems to be an issue with the documentation because the command is in CLI but the screenshot below shows it to be in Legato CLI.

Any help is greatly appreciated.

Hi @akshayrawat91, looks like you’re running the command on the target WP. There is an “update” utility on target, but it doesn’t support multiple arguments, as you’ve noticed. Running the utility on target would be the process (I think) if the update file was already on target. In your case, with the update file on your host, I think you need to be running the same command, but from your host environment, in the Legato shell (i.e. you’ve run “bin/legs” to setup your host environment.)

If I’ve misinterpreted, and the .update file is already on the target, you just need to remove the IP address from the command I think.

Ryan

Hi Ryan,

I tried running the command from the Legato shell and it displays below error.

Hi @akshayrawat91, sorry for the confusion, I meant that you probably want to run that same command, with two parameters, from your host PC. The command failed in the example above because that .update file isn’t available on the WP. It’s available on your host, so, from what I should have described as a shell configured for Legato, you want to run the initial command you tried. Here’s some info on configuring your shell:
https://docs.legato.io/latest/tools.html

Hope that helps,
Ryan